summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2003-02-27 14:22:36 +0000
committerAlexander Larsson <alexl@redhat.com>2003-02-27 14:22:36 +0000
commit83087f783bb067e0809a6648a8bdb14e8e49efbf (patch)
tree102af3c8bdff369d6dc6637d68c668d933dbab0d /configure.in
parentff190005e5e518c1d78fd83b0da3642280ead84c (diff)
2003-02-27 Alexander Larsson <alexl@redhat.com>
* glib/Makefile.am: * configure.in: Make gthreads-2.0 dependency optional. Don't build thread test if its not found.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 281da370..9b969bad 100644
--- a/configure.in
+++ b/configure.in
@@ -218,7 +218,7 @@ AC_SUBST(DBUS_TEST_LIBS)
# Glib detection
PKG_CHECK_MODULES(DBUS_GLIB, glib-2.0, have_glib=yes, have_glib=no)
-PKG_CHECK_MODULES(DBUS_GLIB_THREADS, glib-2.0 gthread-2.0)
+PKG_CHECK_MODULES(DBUS_GLIB_THREADS, glib-2.0 gthread-2.0, have_glib_threads=yes, have_glib_threads=no)
if test x$have_glib = xno ; then
AC_MSG_WARN([GLib development libraries not found])
@@ -235,6 +235,7 @@ if test x$enable_glib = xno; then
fi
AM_CONDITIONAL(HAVE_GLIB, test x$have_glib = xyes)
+AM_CONDITIONAL(HAVE_GLIB_THREADS, test x$have_glib_threads = xyes)
dnl GLib flags
AC_SUBST(DBUS_GLIB_CFLAGS)