summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2007-10-11 10:27:28 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2007-10-11 10:27:28 +0100
commit902beb7c2cba193a7e6292d35eadffb0aae87623 (patch)
treeee7963c149e1aa46d6545ee1fb01597e7f3c4390 /configure.in
parent559de12aac424aa726007abb5cf6a7ac12d39db4 (diff)
Enable Autoconf's AC_C_INLINE to avoid compilation failure with gcc -ansi.
If inline isn't recognised (e.g. on a strict C90 compiler, like gcc -ansi) this defines it to __inline__, __inline or nothing, whichever works. This is safe, because we never use inline except in combination with static.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4ed2e1c0..d2c5e568 100644
--- a/configure.in
+++ b/configure.in
@@ -59,6 +59,7 @@ AM_PROG_CC_C_O
AC_PROG_CXX
AC_ISC_POSIX
AC_HEADER_STDC
+AC_C_INLINE
AC_ARG_ENABLE(tests, AS_HELP_STRING([--enable-tests],[enable unit test code]),enable_tests=$enableval,enable_tests=$USE_MAINTAINER_MODE)
AC_ARG_ENABLE(ansi, AS_HELP_STRING([--enable-ansi],[enable -ansi -pedantic gcc flags]),enable_ansi=$enableval,enable_ansi=no)