summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-03-26 03:58:11 +0000
committerHavoc Pennington <hp@redhat.com>2003-03-26 03:58:11 +0000
commit90ed1d84588a84697051e643175452c50d682ece (patch)
treea8ee3ecb05c584194d5c74e98038c24e5fdabe9b /configure.in
parent17e82f5728d3fc8abd41c816b1c34c506339c7a7 (diff)
2003-03-25 Havoc Pennington <hp@redhat.com>
* throughout - add more _DBUS_ASSERT_ERROR_IS_CLEAR * configure.in: add --with-xml option to specify XML library, right now only libxml is supported. * bus/config-loader-libxml.c, config-parser.c: sync some minor nonworking code between home and work, still just stubs
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 22 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 40557732..552a7cfa 100644
--- a/configure.in
+++ b/configure.in
@@ -31,6 +31,8 @@ AC_ARG_ENABLE(verbose-mode, [ --enable-verbose-mode support verbose debug mode]
AC_ARG_ENABLE(asserts, [ --enable-asserts include assertion checks],enable_asserts=$enableval,enable_asserts=yes)
AC_ARG_ENABLE(gcov, [ --enable-gcov compile with coverage profiling instrumentation (gcc only)],enable_gcov=$enableval,enable_gcov=no)
+AC_ARG_WITH(xml, [ --with-xml=[libxml] XML library to use])
+
dnl DBUS_BUILD_TESTS controls unit tests built in to .c files
dnl and also some stuff in the test/ subdir
AM_CONDITIONAL(DBUS_BUILD_TESTS, test x$enable_tests = xyes)
@@ -45,6 +47,23 @@ if test x$enable_asserts = xno; then
AC_DEFINE(DBUS_DISABLE_ASSERT,1,[Disable assertion checking])
fi
+dbus_use_libxml=false
+dbus_use_fooxml=false
+if test x$with_xml = xfooxml; then
+ dbus_use_fooxml=true
+elif test x$with_xml = xlibxml; then
+ dbus_use_libxml=true
+else
+ with_xml=libxml
+ dbus_use_libxml=true
+fi
+
+AM_CONDITIONAL(DBUS_USE_LIBXML, $dbus_use_libxml)
+if $dbus_use_libxml; then
+ PKG_CHECK_MODULES(LIBXML, libxml-2.0)
+fi
+AM_CONDITIONAL(DBUS_USE_FOOXML, $dbus_use_fooxml)
+
if test "x$GCC" = "xyes"; then
changequote(,)dnl
case " $CFLAGS " in
@@ -224,8 +243,8 @@ DBUS_CLIENT_LIBS=
AC_SUBST(DBUS_CLIENT_CFLAGS)
AC_SUBST(DBUS_CLIENT_LIBS)
-DBUS_BUS_CFLAGS=
-DBUS_BUS_LIBS=
+DBUS_BUS_CFLAGS=$LIBXML_CFLAGS
+DBUS_BUS_LIBS=$LIBXML_LIBS
AC_SUBST(DBUS_BUS_CFLAGS)
AC_SUBST(DBUS_BUS_LIBS)
@@ -329,6 +348,7 @@ echo "
Building assertions: ${enable_asserts}
Building Qt bindings: ${have_qt}
Building GLib bindings: ${have_glib}
+ Using XML parser: ${with_xml}
"
if test x$enable_tests = xyes; then