summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorThiago Macieira <thiago@kde.org>2009-07-16 15:17:25 +0200
committerThiago Macieira <thiago@kde.org>2009-07-16 16:00:57 +0200
commit9f06daccce3f4e75cfac7c97bfb1743affb55cb2 (patch)
treeba1a4fffef795158e8c4ab739234aa156bc35cd5 /configure.in
parent89f70b19495e9c3dadbbb7b51ce1629fa22ea3af (diff)
Fix detection of the GCC __sync intrinsics.
We have to use the return value, otherwise GCC optimises the code by using instructions that don't return anything. That won't match what we actually use in dbus-sysdeps-unix.c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 036679ce..2a0e64e2 100644
--- a/configure.in
+++ b/configure.in
@@ -595,7 +595,7 @@ fi
AC_CACHE_CHECK([whether $CC knows __sync_sub_and_fetch()],
dbus_cv_sync_sub_and_fetch,
[AC_LINK_IFELSE(
- AC_LANG_PROGRAM([], [[int a = 4; __sync_sub_and_fetch(&a, 4);]]),
+ AC_LANG_PROGRAM([], [[int a = 4; int b = __sync_sub_and_fetch(&a, 4);]]),
[dbus_cv_sync_sub_and_fetch=yes],
[dbus_cv_sync_sub_and_fetch=no])
])