summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHarri Porten <porten@kde.org>2002-12-28 09:10:43 +0000
committerHarri Porten <porten@kde.org>2002-12-28 09:10:43 +0000
commitb7354d91569384ba884bd3e391210019037ada2c (patch)
tree7ecb6a83c969afc11b740f687bdd11bda1d14aac /configure.in
parentebd603e725695b58215d2928292c9f1cadd6f3e4 (diff)
very basic check for Qt integration. Another proof that Qt's build
system needs more work for people using it. I didn't want to copy all of KDEs autoconf magic so this is far from perfect, yet. Can we use pkg-config here ?
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in45
1 files changed, 39 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 9806da9e..a2b81699 100644
--- a/configure.in
+++ b/configure.in
@@ -17,11 +17,12 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[The name of the gettext d
AM_MAINTAINER_MODE
AC_PROG_CC
+AC_PROG_CXX
AC_ISC_POSIX
AC_HEADER_STDC
AM_PROG_LIBTOOL
-AC_ARG_ENABLE(qt, [ --enable-qt enable Qt-friendly client library],enable_qt=$enableval,enable_qt=no)
+AC_ARG_ENABLE(qt, [ --enable-qt enable Qt-friendly client library],enable_qt=$enableval,enable_qt=auto)
AC_ARG_ENABLE(glib, [ --enable-glib enable GLib-friendly client library],enable_glib=$enableval,enable_glib=auto)
AC_ARG_ENABLE(tests, [ --enable-tests enable unit test code],enable_tests=yes,enable_tests=no)
AC_ARG_ENABLE(ansi, [ --enable-ansi enable -ansi -pedantic gcc flags],enable_ansi=yes,enable_ansi=no)
@@ -144,11 +145,47 @@ dnl GLib flags
AC_SUBST(DBUS_GLIB_CFLAGS)
AC_SUBST(DBUS_GLIB_LIBS)
+# Qt detection
+have_qt=no
+if test -n "$QTDIR" -a -f $QTDIR/include/qglobal.h; then
+ have_qt=yes
+ DBUS_QT_CXXFLAGS=-I$QTDIR/include
+fi
+
+dnl linking to kdecore will give us a bit of help from libtool
+kdelibs=`kde-config --install lib --expandvars 2>/dev/null`
+if test -z $kdelibs -a -f $kdelibs/libkdecore.la; then
+ have_qt=no
+else
+ DBUS_QT_LIBS=$kdelibs/libkdecore.la
+fi
+
+if test x$have_qt = xno ; then
+ AC_MSG_WARN([Qt development libraries not found])
+fi
+
+if test x$enable_qt = xyes; then
+ if test x$have_qt = xno; then
+ AC_MSG_ERROR([Qt integration explicitly required, and Qt libraries not found])
+ fi
+fi
+
+if test x$enable_qt = xno; then
+ have_qt=no;
+fi
+
+AM_CONDITIONAL(HAVE_QT, test x$have_qt = xyes)
+
+dnl Qt flags
+AC_SUBST(DBUS_QT_CXXFLAGS)
+AC_SUBST(DBUS_QT_LIBS)
+
AC_OUTPUT([
Makefile
Doxyfile
dbus/Makefile
glib/Makefile
+qt/Makefile
bus/Makefile
test/Makefile
doc/Makefile
@@ -166,14 +203,10 @@ echo "
compiler: ${CC}
Building unit tests: ${enable_tests}
- Building Qt bindings: ${enable_qt}
+ Building Qt bindings: ${have_qt}
Building GLib bindings: ${have_glib}
"
if test x$enable_tests = xyes; then
echo "NOTE: building with unit tests increases the size of the installed library"
fi
-if test x$enable_qt = xyes; then
- echo "NOTE: Qt bindings don't actually exist yet"
-fi
-