summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2006-09-05 21:51:58 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2006-09-05 21:51:58 +0000
commitcb51809e9c22d072dbc06359fed57d4d84262685 (patch)
tree0dbf8c811bb5f3d8e06fb334bca158addd696bb8 /configure.in
parentee6964d6a0e4fe82f838d8d352d3c57aea773047 (diff)
* configure.in: Check for no-common compiler flag (OS-X fix from
Benjamin Reed <ranger at befunk dot com>)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9b7fe59a..09019388 100644
--- a/configure.in
+++ b/configure.in
@@ -165,6 +165,14 @@ if test "x$GCC" = "xyes"; then
;;
esac
+ case " $CFLAGS " in
+ *[\ \ ]-fno-common[\ \ ]*) ;;
+ *) if cc_supports_flag -fno-common; then
+ CFLAGS="$CFLAGS -fno-common"
+ fi
+ ;;
+ esac
+
if test "x$enable_ansi" = "xyes"; then
case " $CFLAGS " in
*[\ \ ]-ansi[\ \ ]*) ;;