summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Willcox <jwillcox@gnome.org>2003-05-14 02:40:41 +0000
committerJames Willcox <jwillcox@gnome.org>2003-05-14 02:40:41 +0000
commite9cb382daf7cef6396d1777c99f27a050f7ad4a8 (patch)
treee3cdadde817c2c2d285462ad9d1354a3bc54ec49 /configure.in
parentd4e80132af03363a2f861cfd611847ee8758aed9 (diff)
2003-05-13 James Willcox <jwillcox@gnome.org>
* configure.in: * bus/activation.c: (bus_activation_service_created), (bus_activation_activate_service): * bus/driver.c: (bus_driver_send_service_deleted), (bus_driver_send_service_created), (bus_driver_send_service_lost), (bus_driver_send_service_acquired), (bus_driver_send_welcome_message), (bus_driver_handle_list_services): * bus/session.conf.in: * dbus/dbus-bus.c: (dbus_bus_acquire_service), (dbus_bus_service_exists), (dbus_bus_activate_service): * dbus/dbus-bus.h: Add some convenience API which lets you activate a service, and did a bunch of s/0/DBUS_TYPE_INVALID/ in calls to dbus_message_append_args() and dbus_message_get_args()
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f95da565..1b717747 100644
--- a/configure.in
+++ b/configure.in
@@ -548,6 +548,12 @@ EXPANDED_BINDIR=`eval echo $BINDIR_TMP`
prefix=$old_prefix
AC_SUBST(EXPANDED_BINDIR)
+old_exec_prefix=${exec_prefix}
+test "x$exec_prefix" = xNONE && eval exec_prefix=${prefix}
+eval EXPANDED_LIBDIR=${libdir}
+exec_prefix=${old_exec_prefix}
+AC_SUBST(EXPANDED_LIBDIR)
+
#### Check our operating system
operating_system=unknown
if test -f /etc/redhat-release || test -f $EXPANDED_SYSCONFDIR/redhat-release ; then
@@ -630,6 +636,7 @@ fi
AC_SUBST(DBUS_SESSION_SOCKET_DIR)
+
AC_OUTPUT([
Doxyfile
dbus/dbus-arch-deps.h
@@ -707,4 +714,4 @@ if test x$enable_asserts = xyes; then
fi
if test x$enable_checks = xno; then
echo "NOTE: building without checks for arguments passed to public API makes it harder to debug apps using D-BUS, but will slightly decrease D-BUS library size and _very_ slightly improve performance."
-fi \ No newline at end of file
+fi