summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2009-05-19 22:34:43 +0200
committerLennart Poettering <lennart@poettering.net>2009-05-20 02:09:32 +0200
commitec901d786f6de6e6f870279e2d955f491619c559 (patch)
tree9855d127242c9f910dc3d90ddb2e6267929f711d /configure.in
parent9293e823767daee79386cc797510808f4eed01a3 (diff)
byteswap: make use of glibc specific bytswap primitives
glibc knows three bswap_{16|32|64}() calls that internally make use of a gcc extension to implement faster byteswapping. We should make use of it if we can.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c2c6a8c9..036679ce 100644
--- a/configure.in
+++ b/configure.in
@@ -679,6 +679,8 @@ AC_CHECK_HEADERS(execinfo.h, [AC_CHECK_FUNCS(backtrace)])
AC_CHECK_HEADERS(errno.h)
+AC_CHECK_HEADERS(byteswap.h)
+
AC_CHECK_HEADERS(unistd.h)
# checking for a posix version of getpwnam_r