summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2009-07-10 20:10:12 -0400
committerColin Walters <walters@verbum.org>2009-07-10 20:11:22 -0400
commitf4e15893e5be6da6c7642bb7ef9b14d5531afe41 (patch)
tree6eae4c99652cde63c455356a64705890713ab381 /configure.in
parent98bbe8c7941f2c643dc55b4e7329c0da57d2c7bc (diff)
Bug 22516 - Ensure inotify fd is set close on exec
This prevents it leaking into spawned child processes. Signed-off-by: Colin Walters <walters@verbum.org>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3d159638..3af9cf7c 100644
--- a/configure.in
+++ b/configure.in
@@ -754,7 +754,7 @@ fi
dnl check if inotify backend is enabled
if test x$have_inotify = xyes; then
AC_DEFINE(DBUS_BUS_ENABLE_INOTIFY,1,[Use inotify])
-
+ AC_CHECK_FUNCS(inotify_init1)
fi
AM_CONDITIONAL(DBUS_BUS_ENABLE_INOTIFY, test x$have_inotify = xyes)