summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-04-30 21:15:44 +0000
committerHavoc Pennington <hp@redhat.com>2003-04-30 21:15:44 +0000
commit42d47c5f805b61892456b17a0e5b2632d73745bd (patch)
tree3549facdff6fe32eda39c910ae1239490ef487c6 /dbus/Makefile.am
parent410a80c43126376e9308a03a7cef108716018f5a (diff)
2003-04-30 Havoc Pennington <hp@redhat.com>
* Makefile.am: add a check-local that complains if you didn't configure with --enable-tests
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 8dcb79dd..3e1e0bea 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -154,3 +154,11 @@ dbus_test_LDADD= $(DBUS_CLIENT_LIBS) libdbus-1.la
## mop up the gcov files
clean-local:
/bin/rm *.bb *.bbg *.da *.gcov || true
+
+if DBUS_BUILD_TESTS
+### nothing
+else
+check-local:
+ echo "You have to configure with --enable-tests to make check" ; \
+ exit 1
+endif