summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2005-01-17 03:53:40 +0000
committerHavoc Pennington <hp@redhat.com>2005-01-17 03:53:40 +0000
commit7bf62e31a3c820852271768fafc04ba95c31a19f (patch)
tree660d6e210d04143773da2e86d3b3e8dae8be5cc0 /dbus/Makefile.am
parent4c1a2a760b67b4600db3e5b9c2ad0056b5cf32b6 (diff)
2005-01-16 Havoc Pennington <hp@redhat.com>
This is about it on what can be disabled/deleted from libdbus easily, back below 150K anyhow. Deeper cuts are more work than just turning the code off as I've done here. * dbus/dbus-marshal-basic.c (_dbus_pack_int32): we don't need the signed int convenience funcs * dbus/dbus-internals.c (_dbus_verbose_real): omit when not in verbose mode * dbus/dbus-string-util.c, dbus/dbus-string.c: more breaking things out of libdbus * dbus/dbus-sysdeps.c, dbus/dbus-sysdeps-util.c: same * dbus/dbus-hash.c: purge the TWO_STRINGS crap (well, make it tests-enabled-only, though it should probably be deleted) * dbus/dbus-message-util.c: same stuff * dbus/dbus-auth-util.c: same stuff
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 429c9ad9..216b168d 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -62,15 +62,16 @@ DBUS_LIB_SOURCES= \
dbus-marshal-validate.h \
dbus-message.c \
dbus-message-internal.h \
+ dbus-message-private.h \
dbus-object-tree.c \
dbus-object-tree.h \
dbus-pending-call.c \
dbus-resources.c \
dbus-resources.h \
dbus-server.c \
- dbus-server-protected.h \
dbus-server-debug-pipe.c \
dbus-server-debug-pipe.h \
+ dbus-server-protected.h \
dbus-server-unix.c \
dbus-server-unix.h \
dbus-sha.c \
@@ -121,16 +122,18 @@ DBUS_SHARED_SOURCES= \
### should be underscore-prefixed but don't really need
### to be unless they move to DBUS_SHARED_SOURCES later)
DBUS_UTIL_SOURCES= \
+ dbus-auth-util.c \
dbus-mainloop.c \
dbus-mainloop.h \
+ dbus-marshal-recursive-util.c \
+ dbus-message-util.c \
dbus-spawn.c \
dbus-spawn.h \
+ dbus-string-util.c \
dbus-sysdeps-util.c \
- dbus-sysdeps-util.h \
dbus-test.c \
dbus-test.h \
- dbus-userdb-util.c \
- dbus-userdb-util.h
+ dbus-userdb-util.c
libdbus_1_la_SOURCES= \
$(DBUS_LIB_SOURCES) \