summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2005-01-16 22:13:35 +0000
committerHavoc Pennington <hp@redhat.com>2005-01-16 22:13:35 +0000
commit7f9721a6d36697a57170c604aa845af3531bd157 (patch)
tree4c621bf9671e8c855803bba07ff2d6d87b9baf3d /dbus/Makefile.am
parent31988af4089f3793940417535f8eabaae1ac26c8 (diff)
2005-01-16 Havoc Pennington <hp@redhat.com>
* test/unused-code-gc.py: hacky script to find code that's used only by the bus (not libdbus) or used only by tests or not used at all. It has some false alarms, but looks like we can clean up a lot of size from libdbus. * dbus/dbus-sysdeps.c, dbus/dbus-sysdeps-utils.c, dbus/Makefile.am: initially move 10K of binary size out of libdbus
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 12c9444f..88749a8b 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -75,8 +75,6 @@ DBUS_LIB_SOURCES= \
dbus-server-unix.h \
dbus-sha.c \
dbus-sha.h \
- dbus-test.c \
- dbus-test.h \
dbus-timeout.c \
dbus-timeout.h \
dbus-threads.c \
@@ -109,8 +107,6 @@ DBUS_SHARED_SOURCES= \
dbus-memory.c \
dbus-mempool.c \
dbus-mempool.h \
- dbus-spawn.c \
- dbus-spawn.h \
dbus-string.c \
dbus-string.h \
dbus-string-private.h \
@@ -126,7 +122,13 @@ DBUS_SHARED_SOURCES= \
### to be unless they move to DBUS_SHARED_SOURCES later)
DBUS_UTIL_SOURCES= \
dbus-mainloop.c \
- dbus-mainloop.h
+ dbus-mainloop.h \
+ dbus-spawn.c \
+ dbus-spawn.h \
+ dbus-sysdeps-util.c \
+ dbus-sysdeps-util.h \
+ dbus-test.c \
+ dbus-test.h
libdbus_1_la_SOURCES= \
$(DBUS_LIB_SOURCES) \
@@ -167,7 +169,7 @@ noinst_PROGRAMS=$(TESTS)
dbus_test_SOURCES= \
dbus-test-main.c
-dbus_test_LDADD= $(DBUS_CLIENT_LIBS) libdbus-1.la
+dbus_test_LDADD=libdbus-convenience.la
## mop up the gcov files
clean-local: