summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2006-09-16 17:38:24 +0000
committerHavoc Pennington <hp@redhat.com>2006-09-16 17:38:24 +0000
commit8027efc97b4bec85f674570f878919cb72456745 (patch)
tree441ffafa5367bdb93c8bfa7f8ec51acfeb432b0b /dbus/Makefile.am
parenta0a12210e1f5aa5bd185a57d4394b8eb51cbe472 (diff)
voc Pennington <hp@redhat.com>
* dbus/dbus-server.c (dbus_server_listen): change how this works to be able to delegate to a set of handlers that can succeed, fail, or choose not to handle. Allows us to have dbus_server_listen_platform_specific. * dbus/dbus-server-socket.c (_dbus_server_new_for_tcp_socket): factor out the tcp socket stuff to be used on windows, leaving unix domain socket only in dbus-socket-unix.c * dbus/dbus-transport-socket.c (_dbus_transport_new_for_tcp_socket): factor out the tcp socket stuff to be used on windows, leaving unix domain socket only in dbus-transport-unix.c * dbus/dbus-connection.c (dbus_connection_get_unix_user): insert temporary hack to be sure this fails on windows (dbus_connection_get_unix_process_id): ditto
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 996abe8c..84ee5609 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -62,6 +62,8 @@ DBUS_LIB_SOURCES= \
dbus-server-debug-pipe.c \
dbus-server-debug-pipe.h \
dbus-server-protected.h \
+ dbus-server-socket.c \
+ dbus-server-socket.h \
dbus-server-unix.c \
dbus-server-unix.h \
dbus-sha.c \
@@ -74,6 +76,8 @@ DBUS_LIB_SOURCES= \
dbus-transport.c \
dbus-transport.h \
dbus-transport-protected.h \
+ dbus-transport-socket.c \
+ dbus-transport-socket.h \
dbus-transport-unix.c \
dbus-transport-unix.h \
dbus-watch.c \