summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2009-08-06 22:55:25 +0200
committerLennart Poettering <lennart@poettering.net>2009-10-17 00:28:28 +0200
commit8bc2caac55572bc06c4fc6c2f6e2b28104c9f69c (patch)
tree7fae5fdd18c037e2dab5c7034116137d00d3bb95 /dbus/Makefile.am
parent904319153eb271202853fc15c49b6d8199d3c78e (diff)
move desktop file parser from bus/ to dbus/
We want to make use of it for reading the ConsoleKit database which will need to be implemented in dbus/dbus-userdb-util.c, so let's move this to dbus/.
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am18
1 files changed, 10 insertions, 8 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index e966a438..bf9e1bb5 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -98,8 +98,8 @@ DBUS_LIB_SOURCES= \
## dbus-md5.h \
### source code that goes in the installed client library
-### AND is generic utility functionality used by the
-### daemon or test programs (all symbols in here should
+### AND is generic utility functionality used by the
+### daemon or test programs (all symbols in here should
### be underscore-prefixed)
DBUS_SHARED_SOURCES= \
dbus-dataslot.c \
@@ -128,8 +128,8 @@ DBUS_SHARED_SOURCES= \
### source code that is generic utility functionality used
### by the bus daemon or test apps, but is NOT included
-### in the D-Bus client library (all symbols in here
-### should be underscore-prefixed but don't really need
+### in the D-Bus client library (all symbols in here
+### should be underscore-prefixed but don't really need
### to be unless they move to DBUS_SHARED_SOURCES later)
DBUS_UTIL_SOURCES= \
dbus-auth-util.c \
@@ -151,7 +151,9 @@ DBUS_UTIL_SOURCES= \
dbus-sysdeps-util-unix.c \
dbus-test.c \
dbus-test.h \
- dbus-userdb-util.c
+ dbus-userdb-util.c \
+ dbus-desktop-file.c \
+ dbus-desktop-file.h
libdbus_1_la_SOURCES= \
$(DBUS_LIB_SOURCES) \
@@ -171,14 +173,14 @@ EXTRA_DIST=dbus-arch-deps.h.in
noinst_LTLIBRARIES=libdbus-convenience.la
libdbus_1_la_LIBADD= $(DBUS_CLIENT_LIBS)
-## don't export symbols that start with "_" (we use this
+## don't export symbols that start with "_" (we use this
## convention for internal symbols)
libdbus_1_la_LDFLAGS= -export-symbols-regex "^[^_].*" -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -no-undefined @R_DYNAMIC_LDFLAG@ @PIC_LDFLAGS@
libdbus_convenience_la_LDFLAGS=@R_DYNAMIC_LDFLAG@
## note that TESTS has special meaning (stuff to use in make check)
-## so if adding tests not to be run in make check, don't add them to
+## so if adding tests not to be run in make check, don't add them to
## TESTS
if DBUS_BUILD_TESTS
TESTS_ENVIRONMENT=DBUS_TEST_DATA=$(top_builddir)/test/data DBUS_TEST_HOMEDIR=$(top_builddir)/dbus
@@ -187,7 +189,7 @@ else
TESTS=
endif
-## we use noinst_PROGRAMS not check_PROGRAMS so that we build
+## we use noinst_PROGRAMS not check_PROGRAMS so that we build
## even when not doing "make check"
noinst_PROGRAMS=$(TESTS)