summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2006-07-14 16:20:12 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2006-07-14 16:20:12 +0000
commita929c9a3b465db8b7e17b9b39936c612c2621a7c (patch)
treed1764257d1bd56f8e6a044516ccfc9bc44f7f9f5 /dbus/Makefile.am
parent5efe8e7f1d97931710558495a951e0b35afbfb72 (diff)
* Remove all bindings
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am22
1 files changed, 3 insertions, 19 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 74657ee7..5ceb89d2 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -1,20 +1,6 @@
INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) -DDBUS_COMPILATION
-if HAVE_GLIB
-DBUS_GLIB_BUILT_INCLUDES= \
- dbus-glib-error-enum.h
-
-GLIB_INCLUDES= \
- dbus-glib.h \
- dbus-glib-lowlevel.h \
- $(DBUS_GLIB_BUILT_INCLUDES)
-
-dbus-glib-error-enum.h: dbus-protocol.h make-dbus-glib-error-enum.sh
- $(srcdir)/make-dbus-glib-error-enum.sh $(srcdir)/dbus-protocol.h $@
-
-endif
-
dbusincludedir=$(includedir)/dbus-1.0/dbus
dbusarchincludedir=$(libdir)/dbus-1.0/include/dbus
@@ -35,8 +21,7 @@ dbusinclude_HEADERS= \
dbus-shared.h \
dbus-signature.h \
dbus-threads.h \
- dbus-types.h \
- $(GLIB_INCLUDES)
+ dbus-types.h
dbusarchinclude_HEADERS= \
@@ -158,9 +143,8 @@ libdbus_convenience_la_SOURCES= \
$(DBUS_UTIL_SOURCES)
-BUILT_SOURCES=$(dbusarchinclude_HEADERS) $(DBUS_GLIB_BUILT_INCLUDES)
-EXTRA_DIST=dbus-arch-deps.h.in make-dbus-glib-error-enum.sh
-CLEANFILES=$(DBUS_GLIB_BUILT_INCLUDES)
+BUILT_SOURCES=$(dbusarchinclude_HEADERS)
+EXTRA_DIST=dbus-arch-deps.h.in
## this library is the same as libdbus, but exports all the symbols
## and is only used for static linking within the dbus package.