summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2007-06-15 20:10:09 +0000
committerHavoc Pennington <hp@redhat.com>2007-06-15 20:10:09 +0000
commitb62633b919d481265d3fd75a5d32750dbdc41ddf (patch)
tree03aec003d7c1b9db757c03c39cace5b914b078d6 /dbus/Makefile.am
parent43b944a0a6ea48e8a8b06ae3e638299f591cde8d (diff)
2007-06-15 Havoc Pennington <hp@redhat.com>
* dbus/dbus-sysdeps-unix.c (_dbus_append_session_config_file) (_dbus_append_system_config_file): new functions * bus/main.c (main): use _dbus_append_system_config_file() and _dbus_append_session_config_file() * dbus/Makefile.am (INCLUDES): move DBUS_SYSTEM_CONFIG_FILE and DBUS_SESSION_CONFIG_FILE into this makefile
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index d27ca6f4..81f90b9b 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -1,7 +1,10 @@
configdir=$(sysconfdir)/dbus-1
-INCLUDES=-I$(top_builddir) -I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) -DDBUS_COMPILATION -DDBUS_MACHINE_UUID_FILE=\""$(localstatedir)/lib/dbus/machine-id"\"
+INCLUDES=-I$(top_builddir) -I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) -DDBUS_COMPILATION \
+ -DDBUS_MACHINE_UUID_FILE=\""$(localstatedir)/lib/dbus/machine-id"\" \
+ -DDBUS_SYSTEM_CONFIG_FILE=\""$(configdir)/system.conf"\" \
+ -DDBUS_SESSION_CONFIG_FILE=\""$(configdir)/session.conf"\"
dbusincludedir=$(includedir)/dbus-1.0/dbus
dbusarchincludedir=$(libdir)/dbus-1.0/include/dbus