summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHarald Fernengel <harry@kdevelop.org>2005-09-23 16:24:36 +0000
committerHarald Fernengel <harry@kdevelop.org>2005-09-23 16:24:36 +0000
commitcd883ae0436e0be1234cd0cde3c2e9a8b994d0e8 (patch)
treee911fc2383e9fc4d91cb51774e4037efa439acd2 /dbus/Makefile.am
parentac2de419da28379195da11120ddb0e19f601aa24 (diff)
adding an autotest and "dbus-ify" the build process and include scheme
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index b6b50d70..7e927f21 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -15,6 +15,10 @@ dbus-glib-error-enum.h: dbus-protocol.h make-dbus-glib-error-enum.sh
endif
+if HAVE_QT
+QT_INCLUDES=qdbus.h
+endif
+
dbusincludedir=$(includedir)/dbus-1.0/dbus
dbusarchincludedir=$(libdir)/dbus-1.0/include/dbus
@@ -35,7 +39,8 @@ dbusinclude_HEADERS= \
dbus-shared.h \
dbus-threads.h \
dbus-types.h \
- $(GLIB_INCLUDES)
+ $(GLIB_INCLUDES) \
+ $(QT_INCLUDES)
dbusarchinclude_HEADERS= \
dbus-arch-deps.h