summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-07-08 05:07:32 +0000
committerHavoc Pennington <hp@redhat.com>2003-07-08 05:07:32 +0000
commitd8abf955f5bff3e83cabd267883039f7a42c98c3 (patch)
tree8c3f33fcb6fac2593f44bf5cf8cd48f7a46dce1f /dbus/Makefile.am
parent3f1ad214b5e5c63697ee208d459b304a4ef6e79b (diff)
2003-07-08 Havoc Pennington <hp@pobox.com>
* dbus/dbus-object.h: sketch out an API for registering objects with a connection, that allows us to use as little as 24 bytes per object and lets application code represent an object in any conceivable way. * dbus/dbus-object-registry.c: implement the hard bits of the DBusConnection aspect of object API. Not yet wired up.
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 3c3c14e7..8c919f31 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -17,6 +17,7 @@ dbusinclude_HEADERS= \
dbus-memory.h \
dbus-message.h \
dbus-message-handler.h \
+ dbus-object.h \
dbus-objectid.h \
dbus-protocol.h \
dbus-server.h \
@@ -43,7 +44,10 @@ DBUS_LIB_SOURCES= \
dbus-message.c \
dbus-message-handler.c \
dbus-message-internal.h \
+ dbus-object.c \
dbus-objectid.c \
+ dbus-object-registry.c \
+ dbus-object-registry.h \
dbus-resources.c \
dbus-resources.h \
dbus-server.c \