summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-09-30 03:34:00 +0000
committerHavoc Pennington <hp@redhat.com>2003-09-30 03:34:00 +0000
commit78b69c683ea27514c0787b2d1e2244d7182bc72d (patch)
treede33636f51b016788b75390f87026fcf4d802338 /doc/Makefile.am
parent9a4bd6bf72a8c06227eaf94a59ebf1645faa1e6d (diff)
2003-09-29 Havoc Pennington <hp@pobox.com>
* configure.in: split checks for Doxygen from XML docs, check for xmlto * doc/Makefile.am: XML-ify all the docs, and add a blank dbus-tutorial.xml
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am44
1 files changed, 18 insertions, 26 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 5bd9fb1e..7bd392a6 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,38 +1,30 @@
EXTRA_DIST= \
dbus-specification.html \
- dbus-specification.sgml \
+ dbus-specification.xml \
dbus-test-plan.html \
- dbus-test-plan.sgml \
+ dbus-test-plan.xml \
+ dbus-tutorial.html \
+ dbus-tutorial.xml \
dcop-howto.txt \
file-boilerplate.c
-if DBUS_DOCS_ENABLED
-all-local: dbus-specification.html dbus-test-plan.html
+HTML_FILES= \
+ dbus-specification.html \
+ dbus-test-plan.html \
+ dbus-tutorial.html
+
+if DBUS_XML_DOCS_ENABLED
+all-local: $(HTML_FILES)
endif
-## Debian db2html outputs to stdout, so we collect stdout and use
-## it if we didn't get the proper output
+dbus-specification.html: dbus-specification.xml
+ $(XMLTO) html-nochunks $<
-dbus-specification.html: dbus-specification.sgml
- rm -f $@ && \
- $(DB2HTML) -o . --nochunks $< > $@.stdout && \
- (test -e $@ && rm -f $@.stdout || mv $@.stdout $@) && \
- rm -rf $(srcdir)/dbus-specification/stylesheet-images && \
- (if test -d $(srcdir)/dbus-specification ; then \
- rmdir $(srcdir)/dbus-specification ; fi)
+dbus-test-plan.html: dbus-test-plan.xml
+ $(XMLTO) html-nochunks $<
-dbus-test-plan.html: dbus-test-plan.sgml
- rm -f $@ && \
- $(DB2HTML) -o . --nochunks $< > $@.stdout && \
- (test -e $@ && rm -f $@.stdout || mv $@.stdout $@) && \
- rm -rf $(srcdir)/dbus-test-plan/stylesheet-images && \
- (if test -d $(srcdir)/dbus-test-plan ; then \
- rmdir $(srcdir)/dbus-test-plan ; fi)
+dbus-tutorial.html: dbus-tutorial.xml
+ $(XMLTO) html-nochunks $<
maintainer-clean-local:
- rm -f dbus-test-plan.html
- rm -rf dbus-test-plan/stylesheet-images
- test -d dbus-test-plan && rmdir dbus-test-plan
- rm -f dbus-specification.html
- rm -rf dbus-specification/stylesheet-images
- test -d dbus-specification && rmdir dbus-specification
+ rm -f $(HTML_FILES)