summaryrefslogtreecommitdiffstats
path: root/glib/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2003-02-26 15:52:25 +0000
committerAlexander Larsson <alexl@redhat.com>2003-02-26 15:52:25 +0000
commit89e6dfd29cfbdb92f15e8fb2bde76d94a4c5a7b3 (patch)
tree501540fab4797ab07a4f90e239ac6dabb5bec38d /glib/Makefile.am
parent7265423411609c14ddb9e6643463b840afcaa09b (diff)
2003-02-26 Alexander Larsson <alexl@redhat.com>
* configure.in: Set DBUS_GLIB_THREADS_LIBS for apps using gthread-2.0 * dbus/dbus-connection.c: * dbus/dbus-connection.h: Fix _dbus_connection_acquire_io_path and _dbus_connection_acquire_dispatch. Add dbus_connection_set_wakeup_main_function and use it when queueing incoming and outgoing messages. * dbus/dbus-dataslot.c: Threadsafe usage of DBusDataSlotAllocator * dbus/dbus-message.c: (dbus_message_get_args_iter): dbus_new can fail. * dbus/dbus-server-unix.c: Add todo comment * glib/dbus-gmain.c: Implement the new wakeup functions for glib. * glib/Makefile.am: * glib/test-thread-client.c: * glib/test-thread-server.c: * glib/test-thread.h: Initial cut at some thread test code. Not really done yet.
Diffstat (limited to 'glib/Makefile.am')
-rw-r--r--glib/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/glib/Makefile.am b/glib/Makefile.am
index 6f3906ce..63d2edb9 100644
--- a/glib/Makefile.am
+++ b/glib/Makefile.am
@@ -16,11 +16,23 @@ libdbus_glib_1_la_LIBADD= $(DBUS_GLIB_LIBS) $(top_builddir)/dbus/libdbus-1.la
if DBUS_BUILD_TESTS
-noinst_PROGRAMS= test-dbus-glib
+noinst_PROGRAMS= test-dbus-glib test-thread-server test-thread-client
test_dbus_glib_SOURCES= \
- test-dbus-glib.c
+ test-dbus-glib.c
test_dbus_glib_LDADD= $(top_builddir)/glib/libdbus-glib-1.la
+test_thread_server_SOURCES= \
+ test-thread-server.c \
+ test-thread.h
+
+test_thread_server_LDADD= $(DBUS_GLIB_THREADS_LIBS) $(top_builddir)/glib/libdbus-glib-1.la
+
+test_thread_client_SOURCES= \
+ test-thread-client.c \
+ test-thread.h
+
+test_thread_client_LDADD= $(DBUS_GLIB_THREADS_LIBS) $(top_builddir)/glib/libdbus-glib-1.la
+
endif