summaryrefslogtreecommitdiffstats
path: root/glib/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2005-09-06 22:38:54 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2005-09-06 22:38:54 +0000
commitbc564a69c26419a125eb1880069d9276a47f7d1b (patch)
treef5e5bc7615d0fd4f9b84ebf0001761ef3dd4636c /glib/Makefile.am
parentbbc0cee63702cc344fa399c4ca4e45756bb0b721 (diff)
* Released 0.50dbus-0.50
* Patch from Steve Grubb: - bus/activation.c (bus_activation_service_reload_test): clean up some indentation - dbus/dbus-keyring.c (_dbus_keyring_reload): fix conditional - dbus/dbus-message-factory.c (generate_special): fix a couple of buffer overflows in the test suite. This is non critical because it can not be exploited and this code is only run when doing a make check. * Patch from Yaakov Selkowitz: Build fixes for Cygwin - configure.in: Don't check and link against kdecore, only qt headers - dbus/Makefile.am: Add -no-undefined to libdbus_1_la_LDFLAGS - gcj/org/freedesktop/dbus/Makefile.am: add libdbus_gcj_1_la_LDFLAGS = -no-undefined - glib/Makefile.am: Add -no-undefined to libdbus_glib_1_la_LDFLAGS and $(DBUS_GLIB_LIBS) to dbus_binding_tool_LDADD - qt/Makefile.am: Add -no-undefined to libdbus_qt_1_la_LDFLAGS - tools/Makefile.am: Add platform extentions to binaries (i.e. .exe on windows) * configure.in: - Make it so if no suitable version of python is found we only disable building python instead of exiting the configure script - Require version 2.4 of glib for glib bindings - Up version to 0.50 * python/__init__.py: Sync version with libdbus to (0,50,0)
Diffstat (limited to 'glib/Makefile.am')
-rw-r--r--glib/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/glib/Makefile.am b/glib/Makefile.am
index fd8cba50..6e5c78ee 100644
--- a/glib/Makefile.am
+++ b/glib/Makefile.am
@@ -42,10 +42,10 @@ libdbus_glib_HEADERS = \
libdbus_glibdir = $(includedir)/dbus-1.0/dbus
-libdbus_glib_1_la_LIBADD= $(DBUS_GLIB_LIBS) $(top_builddir)/dbus/libdbus-1.la
+libdbus_glib_1_la_LIBADD= $(top_builddir)/dbus/libdbus-1.la $(DBUS_GLIB_LIBS)
## don't export symbols that start with "_" (we use this
## convention for internal symbols)
-libdbus_glib_1_la_LDFLAGS= -export-symbols-regex "^[^_].*" -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
+libdbus_glib_1_la_LDFLAGS= -export-symbols-regex "^[^_].*" -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -no-undefined
# convenience lib used here and by dbus-viewer
noinst_LTLIBRARIES=libdbus-gtool.la
@@ -67,7 +67,7 @@ dbus_binding_tool_SOURCES = \
dbus-glib-tool.h \
dbus-glib-tool.c
-dbus_binding_tool_LDADD= -lexpat libdbus-gtool.la
+dbus_binding_tool_LDADD= libdbus-gtool.la $(DBUS_GLIB_LIBS) -lexpat
## we just rebuilt these manually and check them into cvs; easier than
## convincing automake/make to do this properly