summaryrefslogtreecommitdiffstats
path: root/glib/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-09-03 02:08:25 +0000
committerHavoc Pennington <hp@redhat.com>2003-09-03 02:08:25 +0000
commitd021cfae6695f0f44102edf758abfc42e2f3c093 (patch)
tree77e95134b676c65557962d50a4eab125a40e6d00 /glib/Makefile.am
parent7b4ac5de11d90e9f7048f057d70d3da5104388b6 (diff)
2003-09-01 Havoc Pennington <hp@pobox.com>
* glib/dbus-gparser.c: implement * glib/dbus-gobject.c: start implementing skeletons support * configure.in: when disabling checks/assert, also define G_DISABLE_ASSERT and G_DISABLE_CHECKS
Diffstat (limited to 'glib/Makefile.am')
-rw-r--r--glib/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/glib/Makefile.am b/glib/Makefile.am
index 3d67db2f..f3b43ed3 100644
--- a/glib/Makefile.am
+++ b/glib/Makefile.am
@@ -1,4 +1,4 @@
-INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS) -DDBUS_COMPILATION=1
+INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS) -DDBUS_COMPILATION=1
dbusincludedir=$(includedir)/dbus-1.0/dbus
@@ -10,6 +10,7 @@ dbusinclude_HEADERS= \
libdbus_glib_1_la_SOURCES = \
dbus-gmain.c \
+ dbus-gobject.c \
dbus-gproxy.c \
dbus-gtest.c \
dbus-gtest.h \
@@ -23,12 +24,13 @@ dbus_glib_tool_SOURCES = \
dbus-gidl.c \
dbus-gidl.h \
dbus-glib-tool.c \
+ dbus-gloader-expat.c \
dbus-gparser.c \
dbus-gparser.h \
dbus-gtool-test.h
-dbus_glib_tool_LDADD= libdbus-glib-1.la $(DBUS_GLIB_LIBS) $(top_builddir)/dbus/libdbus-1.la
+dbus_glib_tool_LDADD= $(DBUS_GLIB_TOOL_LIBS) libdbus-glib-1.la $(top_builddir)/dbus/libdbus-1.la
if DBUS_BUILD_TESTS