summaryrefslogtreecommitdiffstats
path: root/glib/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2004-06-01 03:02:26 +0000
committerHavoc Pennington <hp@redhat.com>2004-06-01 03:02:26 +0000
commite12863aae85dc131fcdd552edd6b32bd15702e12 (patch)
treeed7c53b2388c7136069043f3fa72f64927c95b6f /glib/Makefile.am
parent23e9d3d5040f51870f212ea70a94c9913c90e66b (diff)
2004-05-31 Havoc Pennington <hp@redhat.com>
* glib/dbus-gidl.c (method_info_add_arg): keep args sorted with "in" before "out" * glib/dbus-gobject.c (dbus_type_to_string): move to dbus-gutils.c * glib/dbus-glib-tool.c (main): set up to have a --self-test option that runs the tests, and start filling in some code including for starters just dumping the interfaces to stdout * glib/Makefile.am (INCLUDES): define DBUS_LOCALEDIR * test/data/valid-introspection-files/lots-of-types.xml: test of an example introspection file * glib/dbus-gparser.c (parser_check_doctype): doctype should be "node" (I think...)
Diffstat (limited to 'glib/Makefile.am')
-rw-r--r--glib/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/glib/Makefile.am b/glib/Makefile.am
index c594ece1..5d2172e3 100644
--- a/glib/Makefile.am
+++ b/glib/Makefile.am
@@ -1,4 +1,4 @@
-INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS) -DDBUS_COMPILATION=1
+INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS) -DDBUS_COMPILATION=1 -DDBUS_LOCALEDIR=\"$(prefix)/@DATADIRNAME@/locale\"
dbusincludedir=$(includedir)/dbus-1.0/dbus
@@ -41,8 +41,7 @@ libdbus_gtool_la_LIBADD = libdbus-glib-1.la
bin_PROGRAMS=dbus-glib-tool
dbus_glib_tool_SOURCES = \
- dbus-glib-tool.c \
- dbus-gtool-test.h
+ dbus-glib-tool.c
dbus_glib_tool_LDADD= $(DBUS_GLIB_TOOL_LIBS) libdbus-gtool.la
@@ -58,7 +57,9 @@ noinst_PROGRAMS= $(TESTS)
TESTS_ENVIRONMENT=DBUS_TEST_DATA=$(top_builddir)/test/data DBUS_TEST_HOMEDIR=$(top_builddir)/dbus
TESTS=dbus-glib-test
-dbus_glib_test_SOURCES= \
+## FIXME we aren't running dbus-glib-tool --self-test
+
+dbus_glib_test_SOURCES= \
dbus-gtest-main.c
dbus_glib_test_LDADD= $(top_builddir)/glib/libdbus-glib-1.la