summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2005-09-01 01:22:06 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2005-09-01 01:22:06 +0000
commit236c7b738488b5be33d5ab669479bb22a5f50ec3 (patch)
tree8944bf6db67975a5350c17341a92e1cdd0fa26cf /python/Makefile.am
parent1ea5d42dc058044af3a9ba4b9da62bf4569d54b5 (diff)
* python/Makefile.am: Break on pyrexc errors instead of ignoring them
* python/dbus_bindings.pyx: Memory management foo (global): remove hacky _user_data_references global list (GIL_safe_cunregister_function_handler): userdata now stuffed into tuples. Unref user_data (GIL_safe_cmessage_function_handler): userdata now stuffed into tuples (Connection::__del__): Remove and replace with __dealloc__ method (Connection::add_filter): Stuff user_data into a tuple. Use Py_INCREF to keep tuple from being deallocated instead of the global var hack (Connection::register_object_path): Stuff user_data into a tuple. Use Py_INCREF to keep tuple from being deallocated instead of the global var hack (Connection::register_fallback): Stuff user_data into a tuple. Use Py_INCREF to keep tuple from being deallocated instead of the global var hack (GIL_safe_pending_call_notification): Don't unref the message because it gets unreffed when going out of scope. Py_XDECREF the user_data (PendingCall::__del__): Remove and replace with __dealloc__ method (PendingCall::set_notify): ref the pending call because we will need it to stick around for when the notify callback gets called (Message::__del__): Remove and replace with __dealloc__ method * python/dbus_glib_bindings.pyx (init_gthreads): Changed to gthreads_init to match up with the dbus call * python/glib.py (init_threads): Changed to threads_init to match up with gobject.threads_init(). init_threads is kept for backwards compat but will most likely be deprecated in the future * test/python/test-client.py: - revamp to use Python's unittest functionality - add async call tests - setup threads in glib and dbus so we make sure locks are working
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 52ba8e5b..78bc134b 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -38,8 +38,8 @@ dbus_bindings.pxd: $(srcdir)/dbus_bindings.pxd.in $(srcdir)/extract.py
-$(PYTHON) $(srcdir)/extract.py $(srcdir)/dbus_bindings.pxd.in -I$(srcdir)/$(top_builddir) -I$(srcdir) > $@.tmp && mv $@.tmp $@
dbus_bindings.c: $(srcdir)/dbus_bindings.pyx dbus_bindings.pxd
- -pyrexc $(srcdir)/dbus_bindings.pyx -I. -o ./dbus_bindings.c
+ pyrexc $(srcdir)/dbus_bindings.pyx -I. -o ./dbus_bindings.c
dbus_glib_bindings.c: $(srcdir)/dbus_glib_bindings.pyx dbus_bindings.pxd
- -pyrexc $(srcdir)/dbus_glib_bindings.pyx -I. -o ./dbus_glib_bindings.c
+ pyrexc $(srcdir)/dbus_glib_bindings.pyx -I. -o ./dbus_glib_bindings.c