summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-09-30 02:40:49 +0000
committerHavoc Pennington <hp@redhat.com>2003-09-30 02:40:49 +0000
commit42019c962537b940311573b1ec62495b973b5bfd (patch)
treeef50b1cc74dd6c8ec5e7fc0a8386946363b9ff95 /python/Makefile.am
parentdfd1292d525d01914141cc86013589c6e0ea9d5c (diff)
forgot to add files...
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
new file mode 100644
index 00000000..792dc477
--- /dev/null
+++ b/python/Makefile.am
@@ -0,0 +1,28 @@
+INCLUDES=-I$(top_builddir) -I$(top_builddir)/glib $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS) $(PYTHON_INCLUDES)
+
+dbusdir = $(pythondir)
+dbus_PYTHON = dbus.py
+
+dbusbindingsdir = $(pythondir)
+dbusbindings_LTLIBRARIES = dbus_bindings.la
+
+dbus_bindings_la_LDFLAGS = -module -avoid-version -fPIC -export-symbols-regex initdbus_bindings
+dbus_bindings_la_LIBADD = $(top_builddir)/dbus/libdbus-1.la $(top_builddir)/glib/libdbus-glib-1.la
+dbus_bindings_la_SOURCES = dbus_bindings.c
+
+EXTRA_DIST = \
+ dbus_bindings.pyx.in \
+ extract.py \
+ setup.py \
+ test.py
+
+CLEANFILES = \
+ dbus_bindings.pyx \
+ dbus_bindings.c
+
+
+dbus_bindings.pyx: dbus_bindings.pyx.in extract.py
+ -$(PYTHON) extract.py dbus_bindings.pyx.in -I$(top_builddir) > dbus_bindings.pyx
+
+dbus_bindings.c: dbus_bindings.pyx
+ -pyrexc dbus_bindings.pyx