summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2006-07-14 16:20:12 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2006-07-14 16:20:12 +0000
commita929c9a3b465db8b7e17b9b39936c612c2621a7c (patch)
treed1764257d1bd56f8e6a044516ccfc9bc44f7f9f5 /python/Makefile.am
parent5efe8e7f1d97931710558495a951e0b35afbfb72 (diff)
* Remove all bindings
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am56
1 files changed, 0 insertions, 56 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
deleted file mode 100644
index ea261cb1..00000000
--- a/python/Makefile.am
+++ /dev/null
@@ -1,56 +0,0 @@
-SUBDIRS=examples
-
-INCLUDES=-I$(srcdir)/$(top_builddir) -I$(srcdir)/$(top_builddir)/dbus $(DBUS_CLIENT_CFLAGS) $(PYTHON_INCLUDES) -DDBUS_COMPILATION=1
-
-dbusmoduledir = $(pyexecdir)
-dbusmodule_PYTHON = dbus.pth
-
-dbusdir = $(pyexecdir)/dbus
-dbus_PYTHON = \
- __init__.py \
- _dbus.py \
- decorators.py \
- exceptions.py \
- service.py \
- proxies.py \
- _util.py \
- types.py \
- matchrules.py \
- glib.py \
- introspect_parser.py
-
-dbusbindingsdir = $(pyexecdir)/dbus
-dbusbindings_LTLIBRARIES = dbus_bindings.la dbus_glib_bindings.la
-
-dbus_bindings_la_LDFLAGS = -module -avoid-version -fPIC -export-symbols-regex initdbus_bindings
-dbus_bindings_la_LIBADD = $(top_builddir)/dbus/libdbus-1.la
-nodist_dbus_bindings_la_SOURCES = dbus_bindings.c
-
-dbus_glib_bindings_la_LDFLAGS = -module -avoid-version -fPIC -export-symbols-regex initdbus_glib_bindings
-dbus_glib_bindings_la_LIBADD = $(top_builddir)/dbus/libdbus-1.la $(top_builddir)/glib/libdbus-glib-1.la
-dbus_glib_bindings_la_CFLAGS = $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS)
-nodist_dbus_glib_bindings_la_SOURCES = dbus_glib_bindings.c
-
-
-EXTRA_DIST = \
- dbus_h_wrapper.h \
- dbus_bindings.pyx \
- dbus_glib_bindings.pyx \
- dbus_bindings.pxd.in \
- extract.py
-
-CLEANFILES = \
- dbus_bindings.pxd \
- dbus_bindings.c \
- dbus_glib_bindings.c
-
-
-dbus_bindings.pxd: $(srcdir)/dbus_bindings.pxd.in $(srcdir)/extract.py
- -$(PYTHON) $(srcdir)/extract.py $(srcdir)/dbus_bindings.pxd.in -I$(srcdir)/$(top_builddir) -I$(srcdir) > $@.tmp && mv $@.tmp $@
-
-dbus_bindings.c: $(srcdir)/dbus_bindings.pyx dbus_bindings.pxd
- pyrexc $(srcdir)/dbus_bindings.pyx -I. -o ./dbus_bindings.c
-
-dbus_glib_bindings.c: $(srcdir)/dbus_glib_bindings.pyx dbus_bindings.pxd
- pyrexc $(srcdir)/dbus_glib_bindings.pyx -I. -o ./dbus_glib_bindings.c
-