summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2005-05-01 19:34:58 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2005-05-01 19:34:58 +0000
commitac3b8d0a70f5fee2595ac37182354986f657d333 (patch)
treebdca3bd202fe5a879ab1f2e9ce7cea420718572b /python/Makefile.am
parenteb8bfeb8f2f5c4e6b09043988fc9ab9d178e5276 (diff)
* python/dbus_bindings.pyx.in:
- added new type classes for hinting to the marashaler what type to send over the wire - added int16 and uint16 marshalers - Fixed a bug in the type constants that caused int32 to go out as uint16 over the wire * python/dbus.py: split up into different files and renamed _dbus.py * python/__init__.py, python/_util.py, python/decorators.py, python/exceptions.py, python/proxies.py, python/services.py, python/types.py: new files split off from dbus.py * python/Makefile.am: Add new files, remove dbus.py and install all python files to <python module dir>/dbus * python/examples/*: Added #!/usr/bin/env python to the top of every example. Patch provided by Tatavarty Kalyan
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 25191630..f7a56318 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -2,10 +2,10 @@ SUBDIRS=examples
INCLUDES=-I$(top_builddir) -I$(top_builddir)/dbus $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS) $(PYTHON_INCLUDES)
-dbusdir = $(pythondir)
-dbus_PYTHON = dbus.py
+dbusdir = $(pythondir)/dbus
+dbus_PYTHON = __init__.py _dbus.py decorators.py exceptions.py services.py proxies.py _util.py types.py
-dbusbindingsdir = $(pythondir)
+dbusbindingsdir = $(pythondir)/dbus
dbusbindings_LTLIBRARIES = dbus_bindings.la
dbus_bindings_la_LDFLAGS = -module -avoid-version -fPIC -export-symbols-regex initdbus_bindings