summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2005-07-17 21:02:56 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2005-07-17 21:02:56 +0000
commitafc504f848ebf3840dc80e0a2d529be7dcba8b26 (patch)
tree0ce9918a6c46f88f58c04c1951f6463dbd67fbf4 /python/Makefile.am
parent9a94a1350bb93ea395812dd3c983e13e17c1bcb1 (diff)
* Merge DBUS_0_35_2 branch into HEAD
2005-07-17 John (J5) Palmieri <johnp@redhat.com> * NEWS: Update to 0.35.2 2005-07-17 John (J5) Palmieri <johnp@redhat.com> * python/_dbus.py: Remove import of the dbus.services module as it no longer exists (patch from Dimitur Kirov) * python/service.py (Object::__init__): Fixed typo s/name/bus_name (patch from Dimitur Kirov) * python/examples/example-signal-emitter.py: import dbus.glib to get the main loop and use glib mainloop instead of gtk so X doesn't have to be running. * python/examples/example-signal-recipient.py: import dbus.glib to get the main loop and use glib mainloop instead of gtk so X doesn't have to be running. Import the decorators module directly. * test/glib/Makefile.am: Added DIST_EXTRA files that distcheck didn't pick up on but are needed to build * configure.in: upped version to 0.35.2 * bus/driver.c, bus/selinux.c, bus/selinux.h, dbus/dbus-protocol.h: added Colin Walters' SELinux API rename patch from head s/unix sercurity context/selinux security context/ 2005-07-16 John (J5) Palmieri <johnp@redhat.com> * python/Makefile.am: dbus_binding.pxd.in should be included in EXTRA_DIST not dbus_binding.pxd fix up $(srcdir) hopefully for the last time * NEWS: Update to 0.35.1
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 302ed0d2..3621800a 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -10,19 +10,19 @@ dbusbindings_LTLIBRARIES = dbus_bindings.la dbus_glib_bindings.la
dbus_bindings_la_LDFLAGS = -module -avoid-version -fPIC -export-symbols-regex initdbus_bindings
dbus_bindings_la_LIBADD = $(top_builddir)/dbus/libdbus-1.la
-nodist_dbus_bindings_la_SOURCES = $(srcdir)/dbus_bindings.c
+nodist_dbus_bindings_la_SOURCES = dbus_bindings.c
dbus_glib_bindings_la_LDFLAGS = -module -avoid-version -fPIC -export-symbols-regex initdbus_glib_bindings
dbus_glib_bindings_la_LIBADD = $(top_builddir)/dbus/libdbus-1.la $(top_builddir)/glib/libdbus-glib-1.la
dbus_glib_bindings_la_CFLAGS = $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS)
-nodist_dbus_glib_bindings_la_SOURCES = $(srcdir)/dbus_glib_bindings.c
+nodist_dbus_glib_bindings_la_SOURCES = dbus_glib_bindings.c
EXTRA_DIST = \
dbus_h_wrapper.h \
dbus_bindings.pyx \
dbus_glib_bindings.pyx \
- dbus_bindings.pxd \
+ dbus_bindings.pxd.in \
extract.py
CLEANFILES = \
@@ -32,11 +32,11 @@ CLEANFILES = \
dbus_bindings.pxd: $(srcdir)/dbus_bindings.pxd.in $(srcdir)/extract.py
- -$(PYTHON) $(srcdir)/extract.py $(srcdir)/dbus_bindings.pxd.in -I$(top_builddir) > $@.tmp && mv $@.tmp $@
+ -$(PYTHON) $(srcdir)/extract.py $(srcdir)/dbus_bindings.pxd.in -I$(srcdir)/$(top_builddir) -I$(srcdir) > $@.tmp && mv $@.tmp $@
-dbus_bindings.c: $(srcdir)/dbus_bindings.pyx $(srcdir)/dbus_bindings.pxd
- -pyrexc $(srcdir)/dbus_bindings.pyx
+dbus_bindings.c: $(srcdir)/dbus_bindings.pyx dbus_bindings.pxd
+ -pyrexc $(srcdir)/dbus_bindings.pyx -I. -o ./dbus_bindings.c
-dbus_glib_bindings.c: $(srcdir)/dbus_glib_bindings.pyx $(srcdir)/dbus_bindings.pxd
- -pyrexc $(srcdir)/dbus_glib_bindings.pyx
+dbus_glib_bindings.c: $(srcdir)/dbus_glib_bindings.pyx dbus_bindings.pxd
+ -pyrexc $(srcdir)/dbus_glib_bindings.pyx -I. -o ./dbus_glib_bindings.c