summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2005-05-24 00:21:07 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2005-05-24 00:21:07 +0000
commite43a353d27f1b9643c21ccff53a7759fc3dcdffe (patch)
treead51cf8b4ec9801fe11e012b7453ddb52c51ab44 /python/Makefile.am
parent8af9f11e54317698424bc15ca566e46268646d73 (diff)
* python/decorators.py: import dbus_bindings
* python/matchrules.py (SignalMatchRule, SignalMatchTree, SignalMatchNode): new classes that implement wildcard signal callback matching using a tree lookup. Heavily modified from a patch sent by Celso Pinto (fd.o bug #3241) * _dbus.py (add_signal_receiver, remove_signal_receiver, _signal_func): use new match classes to handle signals.
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 1cd40ee3..23e9cea4 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -3,7 +3,7 @@ SUBDIRS=examples
INCLUDES=-I$(top_builddir) -I$(top_builddir)/dbus $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS) $(PYTHON_INCLUDES)
dbusdir = $(pythondir)/dbus
-dbus_PYTHON = __init__.py _dbus.py decorators.py exceptions.py services.py proxies.py _util.py types.py
+dbus_PYTHON = __init__.py _dbus.py decorators.py exceptions.py services.py proxies.py _util.py types.py matchrules.py
dbusbindingsdir = $(pyexecdir)/dbus
dbusbindings_LTLIBRARIES = dbus_bindings.la