summaryrefslogtreecommitdiffstats
path: root/qt/Makefile.am
diff options
context:
space:
mode:
authorThiago Macieira <thiago@kde.org>2006-03-06 15:27:56 +0000
committerThiago Macieira <thiago@kde.org>2006-03-06 15:27:56 +0000
commit074b0b86747198ee1862ca0450d5192137cccdee (patch)
treeee1d8cdd3757a66fb75bbc690f8af041bb5b4fd2 /qt/Makefile.am
parent12dc0934ae2a1fb92223f84804ad31a57689813c (diff)
2006-03-06 Thiago Macieira <thiago.macieira@trolltech.com>
* qt/dbusidl2cpp.cpp: * qt/Makefile.am: add the dbusidl2cpp tool, the replacement for dcopidl2cpp, found in the KDE installations (or the more modern kalyptus): generate Qt4 C++ code for the input XML introspection. Currently no IDL parsing.
Diffstat (limited to 'qt/Makefile.am')
-rw-r--r--qt/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/qt/Makefile.am b/qt/Makefile.am
index b133ece5..1f87216b 100644
--- a/qt/Makefile.am
+++ b/qt/Makefile.am
@@ -60,6 +60,10 @@ libdbus_qt4_1_la_SOURCES = \
qdbusvariant.h \
qdbusxmlparser_p.h
+bin_PROGRAMS = dbusidl2cpp
+dbusidl2cpp_SOURCES = dbusidl2cpp.cpp
+dbusidl2cpp_LDFLAGS = $(all_libraries) -no-undefined
+dbusidl2cpp_LDADD = $(LIB_QTCORE) libdbus-qt4-1.la
qdbusabstractadaptor.lo: qdbusabstractadaptor.moc qdbusabstractadaptor_p.moc
qdbusserver.lo: qdbusserver.moc