summaryrefslogtreecommitdiffstats
path: root/qt/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2005-03-07 21:10:46 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2005-03-07 21:10:46 +0000
commit076664a5c566a02cd32e19903c158d0ac2bee1ac (patch)
tree3f1600c5fa6ff77f35bf8c0f32d167879265f9f5 /qt/Makefile.am
parentae94f92b5d5692dd4f4084ee9b60e3fe6e44fac5 (diff)
* NEWS: Update for 0.31dbus-0.31.0
* configure.in: Release 0.31 add LT_CURRENT, LT_REVISION, LT_AGE for easy soname bumping * qt/Makefile.am: fixed build * dbus/Makefile.am: soname bump for libdbus * glib/Makefile.am: soname bump for libdbus-glib
Diffstat (limited to 'qt/Makefile.am')
-rw-r--r--qt/Makefile.am22
1 files changed, 16 insertions, 6 deletions
diff --git a/qt/Makefile.am b/qt/Makefile.am
index fd273500..d4e9cdc8 100644
--- a/qt/Makefile.am
+++ b/qt/Makefile.am
@@ -10,12 +10,22 @@ dbusinclude_HEADERS= \
server.h
libdbus_qt_1_la_SOURCES = \
- dbus-qthread.cpp message.cpp connection.cpp \
- integrator.cpp server.cpp integrator.h
-
-connection.cpp: connection.moc
-integrator.cpp: integrator.moc
-server.cpp: server.moc
+ dbus-qthread.cpp \
+ $(top_srcdir)/qt/message.cpp \
+ $(top_srcdir)/qt/connection.cpp \
+ $(top_srcdir)/qt/integrator.cpp \
+ $(top_srcdir)/qt/server.cpp \
+ $(top_srcdir)/qt/connection.h \
+ $(top_srcdir)/qt/integrator.h \
+ $(top_srcdir)/qt/server.h
+
+
+$(top_srcdir)/qt/connection.cpp: connection.moc
+$(top_srcdir)/qt/integrator.cpp: integrator.moc
+$(top_srcdir)/qt/server.cpp: server.moc
+$(top_srcdir)/qt/connection.h: connection.moc
+$(top_srcdir)/qt/integrator.h: integrator.moc
+$(top_srcdir)/qt/server.h: server.moc
CLEANFILES=connection.moc integrator.moc server.moc