summaryrefslogtreecommitdiffstats
path: root/qt/Makefile.am
diff options
context:
space:
mode:
authorZack Rusin <zack@kde.org>2003-11-24 05:21:12 +0000
committerZack Rusin <zack@kde.org>2003-11-24 05:21:12 +0000
commit63a1458aaf2d5fcd0425ec3f6c0dc89d68059206 (patch)
treee3becb5f9bd9aa5d62aa5ffb59c09eb86073ffc7 /qt/Makefile.am
parentfb1df4eaff4f0c562610e440355858892b613cbe (diff)
Seperating integration with D-BUS from Connection to the internal Integrator
class. I simply hated the interfaces in the public Connection when it had to contain a bunch of friends and protected members that were never really meant to be seen.
Diffstat (limited to 'qt/Makefile.am')
-rw-r--r--qt/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/qt/Makefile.am b/qt/Makefile.am
index eb7b1617..168920bf 100644
--- a/qt/Makefile.am
+++ b/qt/Makefile.am
@@ -8,7 +8,8 @@ dbusinclude_HEADERS= \
dbus-qt.h message.h connection.h
libdbus_qt_1_la_SOURCES = \
- dbus-qthread.cpp message.cpp connection.cpp
+ dbus-qthread.cpp message.cpp connection.cpp \
+ integrator.cpp
libdbus_qt_1_la_LIBADD= $(DBUS_QT_LIBS) $(top_builddir)/dbus/libdbus-1.la
libdbus_qt_1_la_LDFLAGS= -version-info 1:0