summaryrefslogtreecommitdiffstats
path: root/qt/Makefile.am
diff options
context:
space:
mode:
authorThiago Macieira <thiago@kde.org>2006-03-28 19:16:35 +0000
committerThiago Macieira <thiago@kde.org>2006-03-28 19:16:35 +0000
commit68b0f5235909a25a7cc4f679592fc7765e845cbf (patch)
tree38c36ef242e25fd3ff7da5a366d4f7f34072cdf6 /qt/Makefile.am
parent26106e12ecdd1a334a7a98a3f2b7205abc7d916d (diff)
* configure.in qt/Makefile.am: add qt/examples
* qt/examples: Add QtDBus example programs: - hello: Hello, World - ping: Simple method-calling program - pong: Simple object-exporting program (not using adaptors) - complexping: Interactive method-calling program (also gets and sets properties). - complexpong: Sample program exporting methods, signals and properties, using adaptors. - dbus: Simple implementation of a generic method-calling program, similar to 'dbus-send', but with semantics similar to 'dcop'. - chat: Simplistic chat program, implemented using signals and the system bus. Looks like IRC.
Diffstat (limited to 'qt/Makefile.am')
-rw-r--r--qt/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/qt/Makefile.am b/qt/Makefile.am
index 74502672..ce35b36f 100644
--- a/qt/Makefile.am
+++ b/qt/Makefile.am
@@ -1,3 +1,5 @@
+SUBDIRS = . examples
+
if HAVE_QT
INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_QT_CFLAGS) -DDBUS_COMPILATION