summaryrefslogtreecommitdiffstats
path: root/qt/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2005-09-06 22:38:54 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2005-09-06 22:38:54 +0000
commitbc564a69c26419a125eb1880069d9276a47f7d1b (patch)
treef5e5bc7615d0fd4f9b84ebf0001761ef3dd4636c /qt/Makefile.am
parentbbc0cee63702cc344fa399c4ca4e45756bb0b721 (diff)
* Released 0.50dbus-0.50
* Patch from Steve Grubb: - bus/activation.c (bus_activation_service_reload_test): clean up some indentation - dbus/dbus-keyring.c (_dbus_keyring_reload): fix conditional - dbus/dbus-message-factory.c (generate_special): fix a couple of buffer overflows in the test suite. This is non critical because it can not be exploited and this code is only run when doing a make check. * Patch from Yaakov Selkowitz: Build fixes for Cygwin - configure.in: Don't check and link against kdecore, only qt headers - dbus/Makefile.am: Add -no-undefined to libdbus_1_la_LDFLAGS - gcj/org/freedesktop/dbus/Makefile.am: add libdbus_gcj_1_la_LDFLAGS = -no-undefined - glib/Makefile.am: Add -no-undefined to libdbus_glib_1_la_LDFLAGS and $(DBUS_GLIB_LIBS) to dbus_binding_tool_LDADD - qt/Makefile.am: Add -no-undefined to libdbus_qt_1_la_LDFLAGS - tools/Makefile.am: Add platform extentions to binaries (i.e. .exe on windows) * configure.in: - Make it so if no suitable version of python is found we only disable building python instead of exiting the configure script - Require version 2.4 of glib for glib bindings - Up version to 0.50 * python/__init__.py: Sync version with libdbus to (0,50,0)
Diffstat (limited to 'qt/Makefile.am')
-rw-r--r--qt/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/qt/Makefile.am b/qt/Makefile.am
index d4e9cdc8..d375bcf3 100644
--- a/qt/Makefile.am
+++ b/qt/Makefile.am
@@ -30,7 +30,7 @@ $(top_srcdir)/qt/server.h: server.moc
CLEANFILES=connection.moc integrator.moc server.moc
libdbus_qt_1_la_LIBADD= $(DBUS_QT_LIBS) $(top_builddir)/dbus/libdbus-1.la
-libdbus_qt_1_la_LDFLAGS= -version-info 1:0
+libdbus_qt_1_la_LDFLAGS= -version-info 1:0 -no-undefined
%.moc: %.h
$(QT_MOC) $< > $@