summaryrefslogtreecommitdiffstats
path: root/qt/Makefile.am
diff options
context:
space:
mode:
authorThiago Macieira <thiago@kde.org>2006-06-04 15:52:05 +0000
committerThiago Macieira <thiago@kde.org>2006-06-04 15:52:05 +0000
commitedbf2bfc109ce94b2604ea20328fda25542e4383 (patch)
tree3281d191fa9dde9f1f26b947b145d02373f031b0 /qt/Makefile.am
parent435c7af9b605c3ffc8641142b6d7add18bf7080b (diff)
* qt/: Update to Subversion r548032.
This includes a big reorganisation of the files inside the subdir. We really need a version control system that supports moving of files. I'm not bothering with history anyways anymore, since the bindings will be moved out to git. The history should be restored from Subversion when that happens.
Diffstat (limited to 'qt/Makefile.am')
-rw-r--r--qt/Makefile.am81
1 files changed, 4 insertions, 77 deletions
diff --git a/qt/Makefile.am b/qt/Makefile.am
index c91c3422..e09fd1e5 100644
--- a/qt/Makefile.am
+++ b/qt/Makefile.am
@@ -1,80 +1,7 @@
-SUBDIRS = . examples
+DIST_SUBDIRS = src tools examples
if HAVE_QT
-INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_QT_CFLAGS) -DDBUS_COMPILATION
-
-lib_LTLIBRARIES=libdbus-qt4-1.la
-
-dbusincludedir=$(includedir)/dbus-1.0/dbus
-dbusinclude_HEADERS= \
- qdbusbus.h \
- qdbusmacros.h \
- qdbuserror.h \
- qdbusmessage.h \
- qdbusserver.h \
- qdbusconnection.h \
- qdbusabstractinterface.h \
- qdbusinterface.h \
- qdbusutil.h \
- qdbusabstractadaptor.h \
- qdbusreply.h \
- qdbustypehelper_p.h
-
-noinst_HEADERS= \
- qdbusabstractadaptor_p.h \
- qdbusabstractinterface_p.h \
- qdbusconnection_p.h \
- qdbusinterface_p.h \
- qdbusintrospection_p.h \
- qdbusmarshall_p.h \
- qdbusmessage_p.h \
- qdbusmetaobject_p.h \
- qdbustype_p.h \
- qdbusxmlparser_p.h
-
-libdbus_qt4_1_la_SOURCES = \
- qdbusbus.cpp \
- qdbusconnection.cpp \
- qdbuserror.cpp \
- qdbusintegrator.cpp \
- qdbusmarshall.cpp \
- qdbusmessage.cpp \
- qdbusserver.cpp \
- qdbustype.cpp \
- qdbusabstractinterface.cpp \
- qdbusinterface.cpp \
- qdbusxmlparser.cpp \
- qdbusutil.cpp \
- qdbusintrospection.cpp \
- qdbusabstractadaptor.cpp \
- qdbusthread.cpp \
- qdbusinternalfilters.cpp \
- qdbusmetaobject.cpp \
- qdbusmisc.cpp \
- qdbusxmlgenerator.cpp
-
-bin_PROGRAMS = dbusidl2cpp dbuscpp2xml
-dbusidl2cpp_SOURCES = dbusidl2cpp.cpp
-dbusidl2cpp_LDFLAGS = -no-undefined
-dbusidl2cpp_LDADD = $(DBUS_QT_LIBS) libdbus-qt4-1.la
-dbuscpp2xml_SOURCES = dbuscpp2xml.cpp
-dbuscpp2xml_LDFLAGS = -no-undefined
-dbuscpp2xml_LDADD = $(DBUS_QT_LIBS) libdbus-qt4-1.la
-
-qdbusabstractadaptor.lo: qdbusabstractadaptor.moc qdbusabstractadaptor_p.moc
-qdbusabstractinterface.lo: qdbusabstractinterface.moc
-qdbusbus.lo: qdbusbus.moc
-qdbusserver.lo: qdbusserver.moc
-qdbusintegrator.lo: qdbusconnection_p.moc
-
-CLEANFILES=qdbusabstractadaptor.moc qdbusserver.moc qdbusconnection_p.moc qdbusconnection_p.moc qdbusabstractadaptor_p.moc qdbusbus.moc qdbusabstractinterface.moc
-
-libdbus_qt4_1_la_LIBADD= $(DBUS_QT_LIBS) $(top_builddir)/dbus/libdbus-1.la
-libdbus_qt4_1_la_LDFLAGS= -version-info 1:0 -no-undefined
-libdbus_qt4_1_la_CPPFLAGS= -DQDBUS_MAKEDLL
-
-EXTRA_DIST = qt-dbus.qdocconf
-
-%.moc: %.h
- $(QT_MOC) $< > $@
+QT_SUBDIRS = src tools examples
endif
+
+SUBDIRS = $(QT_SUBDIRS)