summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-04-05 00:37:17 +0000
committerHavoc Pennington <hp@redhat.com>2003-04-05 00:37:17 +0000
commit03b9ca6d4ecf2577958530b8390d675c73a58825 (patch)
treebe0569a447ef9acaf5a0004fb9bfe1a2022c9eb1 /test/Makefile.am
parent45d1479fad0fb55f1775c394e696643dad3e8e4d (diff)
2003-04-04 Havoc Pennington <hp@redhat.com>
* dbus/dbus-spawn.c, dbus/dbus-spawn.h: Change dbus_spawn to return a "babysitter" object that is used to monitor the status of the spawned process and reap it when required. * test/test-segfault.c, test/test-exit.c, test/test-sleep-forever.c: binaries that do various lame things, used in the test suite. * dbus/dbus-sysdeps.c: kill _dbus_errno_to_string()
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index d0429aaf..c46b2797 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -2,7 +2,7 @@
INCLUDES=-I$(top_srcdir) $(DBUS_TEST_CFLAGS)
if DBUS_BUILD_TESTS
-TEST_BINARIES=test-service echo-client echo-server unbase64 break-loader spawn-test
+TEST_BINARIES=test-service echo-client echo-server unbase64 break-loader spawn-test test-segfault test-exit test-sleep-forever
else
TEST_BINARIES=
endif
@@ -40,6 +40,15 @@ break_loader_SOURCES= \
spawn_test_SOURCES= \
spawn-test.c
+test_exit_SOURCES = \
+ test-exit.c
+
+test_segfault_SOURCES = \
+ test-segfault.c
+
+test_sleep_forever_SOURCES = \
+ test-sleep-forever.c
+
TEST_LIBS=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la
echo_client_LDADD=$(TEST_LIBS)