summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-01-28 03:53:29 +0000
committerHavoc Pennington <hp@redhat.com>2003-01-28 03:53:29 +0000
commit05a4ad6994919b352b5229d0b1b0a8ebebe2a42f (patch)
treeef8adeefdea46a6ae4b673cd4014d5f8d2ea792b /test/Makefile.am
parentee1133de4dc5e181be5d09f084d8823388d5f693 (diff)
2003-01-27 Havoc Pennington <hp@pobox.com>
* dbus/dbus-mempool.c (time_for_size): replace printf with _dbus_verbose * dbus/dbus-message-builder.c (_dbus_message_data_load): allow empty lines; fix the SAVE_LENGTH stuff to be START_LENGTH/END_LENGTH so it actually works; couple other bugfixes * test/Makefile.am (dist-hook): add dist-hook for .message files * dbus/dbus-string.c (DBUS_STRING_COPY_PREAMBLE): source of a copy can be constant or locked. (_dbus_string_free): allow freeing a const string as documented/intended * dbus/dbus-sysdeps.c (_dbus_concat_dir_and_file): utility * dbus/dbus-test-main.c (main): take an argument which is the directory containing test data * dbus/dbus-message.c (_dbus_message_test): pass a test_data_dir argument to this and load all the messages in test/data/ checking that they can be loaded or not loaded as appropriate.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 4ddf2603..f0118ee6 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -24,3 +24,13 @@ TEST_LIBS=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la $(top_bu
echo_client_LDADD=$(TEST_LIBS)
echo_server_LDADD=$(TEST_LIBS)
+dist-hook:
+ DIRS="data data/valid-messages" ; \
+ for D in $DIRS; do \
+ test -d $(distdir)/$D || mkdir $(distdir)/$D ; \
+ done ; \
+ FILES=`find -name "*.message"` ; \
+ for F in $FILES; do \
+ echo '-- Disting file '$$F ; \
+ cp $F $(distdir)/$$F ; \
+ done