summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2005-07-14 20:44:15 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2005-07-14 20:44:15 +0000
commit075945f611290f2b9db9a4ed6cf5433f2fd85785 (patch)
tree4430967edcace655eabbc4689299b1ad45aa3a61 /test/Makefile.am
parent955cc78770c03edd9b88d5d73ba53901016ddf60 (diff)
Checking in Rodrigo's patch along with my fixes to the patch
2005-07-14 John (J5) Palmieri <johnp@redhat.com> * bus/activation.c: clean up all tabs to be 8 spaces (bus_activation_activate_service): make sure we clean up if activation fails * bus/dispatch.c: clean up all tabs to be 8 spaces (check_shell_fail_service_auto_start): New function tests to make sure we get fail properly when trying to auto start a service with a faulty command line (check_shell_service_success_auto_start): New function tests to make sure auto started services get the arguments on the command line * test/test-shell-service.c: Added service for testing auto-starting with command line arguments * test/data/valid-service-files/debug-shell-echo-fail.service.in, test/data/valid-service-files/debug-shell-echo-success.service.in: Added service files for testing auto-starting with command line arguments * */.cvsignore: added a bunch of generated files to various .cvsignore files 2005-07-14 Rodrigo Moya <rodrigo@novell.com> * dbus/dbus-shell.[ch]: copy/pasted code from GLib. * dbus/Makefile.am: added new files to build. * bus/activation.c (bus_activation_activate_service): support activation commands with parameters. * test/shell-test.c: added test program for the shell parsing code.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 4498b7e3..27f51023 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -11,9 +11,13 @@ INCLUDES=-I$(top_srcdir) $(DBUS_TEST_CFLAGS)
if DBUS_BUILD_TESTS
## break-loader removed for now
-TEST_BINARIES=test-service spawn-test test-segfault test-exit test-sleep-forever
+TEST_BINARIES=test-service test-shell-service shell-test spawn-test test-segfault test-exit test-sleep-forever
+
+#enable stand alone make check test
+TESTS=shell-test
else
TEST_BINARIES=
+TESTS=
endif
if DBUS_GCOV_ENABLED
@@ -32,6 +36,14 @@ test_service_SOURCES= \
##break_loader_SOURCES= \
## break-loader.c
+test_shell_service_SOURCES = \
+ test-shell-service.c \
+ test-utils.c \
+ test-utils.h
+
+shell_test_SOURCES= \
+ shell-test.c
+
spawn_test_SOURCES= \
spawn-test.c
@@ -51,6 +63,8 @@ TEST_LIBS=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la
test_service_LDADD=$(TEST_LIBS)
## break_loader_LDADD= $(TEST_LIBS)
+test_shell_service_LDADD=$(TEST_LIBS)
+shell_test_LDADD=$(TEST_LIBS)
spawn_test_LDADD=$(TEST_LIBS)
decode_gcov_LDADD=$(TEST_LIBS)