summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorWaldo Bastian <bastian@kde.org>2005-09-12 08:19:33 +0000
committerWaldo Bastian <bastian@kde.org>2005-09-12 08:19:33 +0000
commit8b34c2c538f182fe29af58f5153b9dd7cdbaf7fa (patch)
treefa5deb39e5b291180a67947d98607809a2a5ff59 /test/Makefile.am
parent5e8110d79aa8c11ad76b3e77791e3e6daca0fa32 (diff)
* dbus/dbus-marshal-validate.c, doc/dbus-specification.xml,
test/Makefile.am, test/test-names.c: allow hyphens in bus names.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index e0a25aa4..5f904887 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -14,7 +14,7 @@ INCLUDES=-I$(top_srcdir) $(DBUS_TEST_CFLAGS)
if DBUS_BUILD_TESTS
## break-loader removed for now
-TEST_BINARIES=test-service test-shell-service shell-test spawn-test test-segfault test-exit test-sleep-forever
+TEST_BINARIES=test-service test-names test-shell-service shell-test spawn-test test-segfault test-exit test-sleep-forever
#enable stand alone make check test
TESTS=shell-test
@@ -36,6 +36,11 @@ test_service_SOURCES= \
test-utils.c \
test-utils.h
+test_names_SOURCES= \
+ test-names.c \
+ test-utils.c \
+ test-utils.h
+
##break_loader_SOURCES= \
## break-loader.c
@@ -65,6 +70,7 @@ decode_gcov_SOURCES= \
TEST_LIBS=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la
test_service_LDADD=$(TEST_LIBS)
+test_names_LDADD=$(TEST_LIBS)
## break_loader_LDADD= $(TEST_LIBS)
test_shell_service_LDADD=$(TEST_LIBS)
shell_test_LDADD=$(TEST_LIBS)