summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAnders Carlsson <andersca@codefactory.se>2003-02-02 15:24:48 +0000
committerAnders Carlsson <andersca@codefactory.se>2003-02-02 15:24:48 +0000
commitbb6a24ae1c9cf07ab733849c12752748638c02a3 (patch)
tree2a9bc5129f75566d5d8d7741498ee8c1175e3471 /test/Makefile.am
parent3a742628606c07d66891338429efc63ca2cd5f4d (diff)
2003-02-02 Anders Carlsson <andersca@codefactory.se>
* test/Makefile.am: * test/bus-test.c: (get_time), (add_timeout), (remove_timeout), (message_handler), (new_connection_callback), (loop_quit), (loop_run), (main): Add bus test.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index f5933b77..fc218b7c 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -2,7 +2,7 @@
INCLUDES=-I$(top_srcdir) $(DBUS_TEST_CFLAGS)
if DBUS_BUILD_TESTS
-TEST_BINARIES=echo-client echo-server unbase64
+TEST_BINARIES=echo-client echo-server unbase64 bus-test
else
TEST_BINARIES=
endif
@@ -23,11 +23,15 @@ unbase64_SOURCES= \
unbase64.c
+bus_test_SOURCES = \
+ bus-test.c
+
TEST_LIBS=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la $(top_builddir)/dbus/libdbus-1.la
echo_client_LDADD=$(TEST_LIBS)
echo_server_LDADD=$(TEST_LIBS)
unbase64_LDADD=$(TEST_LIBS)
+bus_test_LDADD=$(TEST_LIBS) $(top_builddir)/bus/libdbus-daemon.la
dist-hook:
DIRS="data data/valid-messages data/invalid-messages data/incomplete-messages" ; \