summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-01-28 19:56:41 +0000
committerHavoc Pennington <hp@redhat.com>2003-01-28 19:56:41 +0000
commitdef834b73b7e306790437b3d02613b14a94e6655 (patch)
tree0a48289d171059ebd5778a5fa60c1a0de3fc7d4b /test/Makefile.am
parentd02b7cd060dea848c79afa71eb0364eaa47379ff (diff)
2003-01-28 Havoc Pennington <hp@redhat.com>
* dbus/dbus-string.c (_dbus_string_base64_decode): append bytes in the reverse order from how I had it (_dbus_string_base64_encode): reverse encoding order. I was basically byteswapping everything during encoding.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index a2139166..f5933b77 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -2,7 +2,7 @@
INCLUDES=-I$(top_srcdir) $(DBUS_TEST_CFLAGS)
if DBUS_BUILD_TESTS
-TEST_BINARIES=echo-client echo-server
+TEST_BINARIES=echo-client echo-server unbase64
else
TEST_BINARIES=
endif
@@ -19,10 +19,15 @@ echo_server_SOURCES= \
watch.c \
watch.h
+unbase64_SOURCES= \
+ unbase64.c
+
+
TEST_LIBS=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la $(top_builddir)/dbus/libdbus-1.la
echo_client_LDADD=$(TEST_LIBS)
echo_server_LDADD=$(TEST_LIBS)
+unbase64_LDADD=$(TEST_LIBS)
dist-hook:
DIRS="data data/valid-messages data/invalid-messages data/incomplete-messages" ; \