summaryrefslogtreecommitdiffstats
path: root/test/name-test/Makefile.am
diff options
context:
space:
mode:
authorScott James Remnant <scott@ubuntu.com>2009-05-11 23:29:52 +0100
committerColin Walters <walters@verbum.org>2009-07-14 15:38:42 -0400
commit0539a23c661f028da63526996b6463ef342bb4f3 (patch)
treea02a4c05a9dfe230dbdfdc39577ab6e23b7be6e8 /test/name-test/Makefile.am
parent21b0ff273a69d19e505b71c263725302aa5b025f (diff)
Add tests for pending call timeouts
* test/test-service.c (handle_delay_echo, path_message_func): Add a variant of the Echo method which sleeps for a short time. * test/name-test/test-pending-call-timeout.c: Run tests with default, specified and infinite timeout to make sure we get the reply. * test/name-test/run-test.sh: Run the new test * test/name-test/Makefile.am: Build the new test Signed-off-by: Scott James Remnant <scott@ubuntu.com> (cherry picked from commit c1f165261afcc3bafa9b24ff916bb231628e3782)
Diffstat (limited to 'test/name-test/Makefile.am')
-rw-r--r--test/name-test/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/test/name-test/Makefile.am b/test/name-test/Makefile.am
index 10a2536d..1c73b877 100644
--- a/test/name-test/Makefile.am
+++ b/test/name-test/Makefile.am
@@ -16,7 +16,7 @@ if DBUS_BUILD_TESTS
## we use noinst_PROGRAMS not check_PROGRAMS for TESTS so that we
## build even when not doing "make check"
-noinst_PROGRAMS=test-names test-pending-call-dispatch test-threads-init test-ids test-shutdown test-privserver test-privserver-client
+noinst_PROGRAMS=test-names test-pending-call-dispatch test-pending-call-timeout test-threads-init test-ids test-shutdown test-privserver test-privserver-client
test_names_SOURCES= \
test-names.c
@@ -30,6 +30,12 @@ test_pending_call_dispatch_SOURCES = \
test_pending_call_dispatch_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_TEST_LIBS)
test_pending_call_dispatch_LDFLAGS=@R_DYNAMIC_LDFLAG@
+test_pending_call_timeout_SOURCES = \
+ test-pending-call-timeout.c
+
+test_pending_call_timeout_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_TEST_LIBS)
+test_pending_call_timeout_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
test_threads_init_SOURCES = \
test-threads-init.c