summaryrefslogtreecommitdiffstats
path: root/test/name-test/Makefile.am
diff options
context:
space:
mode:
authorScott James Remnant <scott@ubuntu.com>2009-05-11 23:29:52 +0100
committerScott James Remnant <scott@ubuntu.com>2009-05-28 11:47:38 +0200
commitc1f165261afcc3bafa9b24ff916bb231628e3782 (patch)
tree36ca4ba1c052da63c037789db5fc977f7f784fba /test/name-test/Makefile.am
parentbd2063e17e1bb57dee1a5dfed76c9dde76d55ff3 (diff)
Add tests for pending call timeouts
* test/test-service.c (handle_delay_echo, path_message_func): Add a variant of the Echo method which sleeps for a short time. * test/name-test/test-pending-call-timeout.c: Run tests with default, specified and infinite timeout to make sure we get the reply. * test/name-test/run-test.sh: Run the new test * test/name-test/Makefile.am: Build the new test Signed-off-by: Scott James Remnant <scott@ubuntu.com>
Diffstat (limited to 'test/name-test/Makefile.am')
-rw-r--r--test/name-test/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/test/name-test/Makefile.am b/test/name-test/Makefile.am
index 10a2536d..1c73b877 100644
--- a/test/name-test/Makefile.am
+++ b/test/name-test/Makefile.am
@@ -16,7 +16,7 @@ if DBUS_BUILD_TESTS
## we use noinst_PROGRAMS not check_PROGRAMS for TESTS so that we
## build even when not doing "make check"
-noinst_PROGRAMS=test-names test-pending-call-dispatch test-threads-init test-ids test-shutdown test-privserver test-privserver-client
+noinst_PROGRAMS=test-names test-pending-call-dispatch test-pending-call-timeout test-threads-init test-ids test-shutdown test-privserver test-privserver-client
test_names_SOURCES= \
test-names.c
@@ -30,6 +30,12 @@ test_pending_call_dispatch_SOURCES = \
test_pending_call_dispatch_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_TEST_LIBS)
test_pending_call_dispatch_LDFLAGS=@R_DYNAMIC_LDFLAG@
+test_pending_call_timeout_SOURCES = \
+ test-pending-call-timeout.c
+
+test_pending_call_timeout_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_TEST_LIBS)
+test_pending_call_timeout_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
test_threads_init_SOURCES = \
test-threads-init.c