summaryrefslogtreecommitdiffstats
path: root/test/qt/Makefile.am
diff options
context:
space:
mode:
authorThiago Macieira <thiago@kde.org>2006-03-28 18:58:58 +0000
committerThiago Macieira <thiago@kde.org>2006-03-28 18:58:58 +0000
commitd54ababd5f67bb621c1b3a911d0853c23df817a1 (patch)
tree8ff32adfe2806e65e69a6965d75efe00fc97b7ff /test/qt/Makefile.am
parentd42c8663e8fd441838a238bfb845a7c80c37b253 (diff)
* test/qt/*: Sync with KDE Subversion revision 523647.
Update the testcases to the new API. Remove testcases for classes that are no longer public or have been removed.
Diffstat (limited to 'test/qt/Makefile.am')
-rw-r--r--test/qt/Makefile.am12
1 files changed, 3 insertions, 9 deletions
diff --git a/test/qt/Makefile.am b/test/qt/Makefile.am
index 94283eb4..f7a8efa9 100644
--- a/test/qt/Makefile.am
+++ b/test/qt/Makefile.am
@@ -1,33 +1,26 @@
INCLUDES=-I$(top_srcdir) -I$(top_srcdir)/qt $(DBUS_CLIENT_CFLAGS) $(DBUS_QT_CFLAGS) $(DBUS_QTESTLIB_CFLAGS) -DDBUS_COMPILATION
if DBUS_BUILD_TESTS
-TEST_BINARIES=qdbustype qdbusxmlparser qdbusconnection qpong ping qdbusobject qdbusinterface qdbusabstractadaptor hal
+TEST_BINARIES=qdbusconnection qpong ping qdbusinterface qdbusabstractadaptor hal
TESTS=
else
TEST_BINARIES=
TESTS=
endif
-
noinst_PROGRAMS= $(TEST_BINARIES)
qpong_SOURCES= qpong.cpp
ping_SOURCES= ping.cpp
qdbusconnection_SOURCES= tst_qdbusconnection.cpp
-qdbusobject_SOURCES= tst_qdbusobject.cpp
qdbusinterface_SOURCES= tst_qdbusinterface.cpp
-qdbustype_SOURCES= tst_qdbustype.cpp
-qdbusxmlparser_SOURCES= tst_qdbusxmlparser.cpp common.h
qdbusabstractadaptor_SOURCES= tst_qdbusabstractadaptor.cpp common.h
hal_SOURCES = tst_hal.cpp
qpong.o: qpong.moc
ping.o: ping.moc
tst_qdbusconnection.o: tst_qdbusconnection.moc
-tst_qdbusobject.o: tst_qdbusobject.moc
tst_qdbusinterface.o: tst_qdbusinterface.moc
-tst_qdbustype.o: tst_qdbustype.moc
-tst_qdbusxmlparser.o: tst_qdbusxmlparser.moc
tst_qdbusabstractadaptor.o: tst_qdbusabstractadaptor.moc
tst_hal.o: tst_hal.moc
@@ -38,4 +31,5 @@ TEST_LIBS=$(DBUS_QTESTLIB_LIBS) $(top_builddir)/qt/libdbus-qt4-1.la
LDADD=$(TEST_LIBS)
-CLEANFILES=tst_qdbusconnection.moc
+clean-local:
+ -rm *.moc