summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-04-14 03:25:19 +0000
committerHavoc Pennington <hp@redhat.com>2003-04-14 03:25:19 +0000
commit7c434a849a161c4514f3759659ac7af9ecddc721 (patch)
tree44585521fe21e086e463ee33df7d0556214192a4 /tools/Makefile.am
parent777707ed8dff6958972a93894a87ec1945c65c14 (diff)
2003-04-13 Havoc Pennington <hp@pobox.com>
* tools/dbus-send.c, tools/dbus-monitor.c: two utility programs from Philip Blundell to send messages and monitor them.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
new file mode 100644
index 00000000..f1f9dbac
--- /dev/null
+++ b/tools/Makefile.am
@@ -0,0 +1,18 @@
+INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS)
+
+if HAVE_GLIB
+GLIB_TOOLS=dbus-monitor
+else
+GLIB_TOOLS=
+endif
+
+bin_PROGRAMS=dbus-send $(GLIB_TOOLS)
+
+dbus_send_SOURCES= \
+ dbus-send.c
+
+dbus_monitor_SOURCES= \
+ dbus-monitor.c
+
+dbus_send_LDADD= $(top_builddir)/dbus/libdbus-1.la
+dbus_monitor_LDADD= $(top_builddir)/glib/libdbus-glib-1.la