summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2005-03-17 17:48:29 +0000
committerColin Walters <walters@verbum.org>2005-03-17 17:48:29 +0000
commita65587676f6791ff6a7c9ed98bbc53d740f51fa8 (patch)
tree1e5fb5030cf55dc63dc388e6da4a7918dfa9251f /tools/Makefile.am
parent6180ae6941aea083f5b8f3c4d3f16c928935bcaf (diff)
2005-03-17 Colin Walters <walters@verbum.org>
* bus/print-introspect.c: Move to tools/. * bus/run-with-tmp-session-bus.sh: Ditto. * glib/Makefile.am (dbus-glib-bindings.h): Move generation to tools/Makefile.am. * test/glib/run-test.sh: Update to handle move of run-with-tmp-session-bus.sh. * test/glib/test-service-glib.c: Update to handle move of dbus-glib-bindings.h. * tools/print-introspect.c: Moved here from bus/, and ported to GLib bindings. * tools/run-with-tmp-session-bus.sh: Moved here from bus/. * tools/Makefile.am: Generate dbus-glib-bindings.h and dbus-bus-introspect.xml here. * tools/.cvsignore, glib/.cvsignore, bus/.cvsignore: Update.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 7cc6cadf..aeb6d6ce 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -2,6 +2,15 @@ INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_X_CFLA
if HAVE_GLIB
GLIB_TOOLS=dbus-monitor
+
+libdbus_glib_HEADERS = dbus-glib-bindings.h
+libdbus_glibdir = $(includedir)/dbus-1.0/dbus
+
+dbus-glib-bindings.h: dbus-bus-introspect.xml $(top_builddir)/glib/dbus-binding-tool
+ $(top_builddir)/glib/dbus-binding-tool --ignore-unsupported --mode=glib-client --output=dbus-glib-bindings.h dbus-bus-introspect.xml # FIXME - remove --ignore-unsupported when we can do arrays
+
+BUILT_SOURCES = dbus-glib-bindings.h
+
else
GLIB_TOOLS=
endif
@@ -12,6 +21,16 @@ else
GTK_TOOLS=
endif
+noinst_PROGRAMS = print-introspect
+
+print_introspect_SOURCES = print-introspect.c
+print_introspect_LDADD = $(top_builddir)/glib/libdbus-glib-1.la
+
+run-with-tmp-session-bus.sh: $(top_builddir)/bus/dbus-daemon dbus-launch
+
+dbus-bus-introspect.xml: $(srcdir)/run-with-tmp-session-bus.sh print-introspect $(top_builddir)/bus/dbus-daemon
+ DBUS_TOP_BUILDDIR=$(top_builddir) $(srcdir)/run-with-tmp-session-bus.sh ./print-introspect org.freedesktop.DBus /org/freedesktop/DBus > dbus-bus-introspect.xml.tmp && mv dbus-bus-introspect.xml.tmp dbus-bus-introspect.xml
+
bin_PROGRAMS=dbus-send $(GLIB_TOOLS) dbus-launch dbus-cleanup-sockets $(GTK_TOOLS)
dbus_send_SOURCES= \
@@ -43,6 +62,6 @@ dbus_launch_LDADD= $(DBUS_X_LIBS)
dbus_viewer_LDADD= $(DBUS_GLIB_TOOL_LIBS) $(top_builddir)/glib/libdbus-gtool.la $(DBUS_GTK_THREADS_LIBS)
man_MANS = dbus-send.1 dbus-monitor.1 dbus-launch.1 dbus-cleanup-sockets.1
-EXTRA_DIST = $(man_MANS)
+EXTRA_DIST = $(man_MANS) run-with-tmp-session-bus.sh