summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 47329972..200ee64e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,6 +20,13 @@ if HAVE_PYTHON
PYTHON_SUBDIR=python
endif
+## really we should require gcj/mcs/python also but since they are
+## annoying to install, we don't for now
+dist-local:
+ if test -z "$(QT_SUBDIR)" || test -z "$(GLIB_SUBDIR)" ; then \
+ echo "You have to build with Qt and GLib to make dist" ; \
+ fi
+
SUBDIRS=dbus bus doc $(GLIB_SUBDIR) $(GCJ_SUBDIR) $(MONO_SUBDIR) $(QT_SUBDIR) $(PYTHON_SUBDIR) test tools
pkgconfigdir = $(libdir)/pkgconfig