summaryrefslogtreecommitdiffstats
path: root/cmake/test/name-test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cmake/test/name-test/CMakeLists.txt')
-rw-r--r--cmake/test/name-test/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/cmake/test/name-test/CMakeLists.txt b/cmake/test/name-test/CMakeLists.txt
new file mode 100644
index 00000000..3b8f39ec
--- /dev/null
+++ b/cmake/test/name-test/CMakeLists.txt
@@ -0,0 +1,25 @@
+if (DBUS_BUILD_TESTS)
+
+set (NAMEtest-DIR ../../../test/name-test)
+
+include_directories( ${CMAKE_SOURCE_DIR}/.. )
+include_directories( ${CMAKE_INCLUDE_PATH} )
+add_definitions(-DDBUS_COMPILATION)
+
+# there is also a test-names executable, don't know if this is the same
+add_executable(test-names1 ${NAMEtest-DIR}/test-names.c)
+target_link_libraries(test-names1 dbus-1)
+install_targets(/bin test-names1)
+ADD_TEST(test-names ${EXECUTABLE_OUTPUT_PATH}/test-names1)
+
+add_executable(test-pending-call-dispatch ${NAMEtest-DIR}/test-pending-call-dispatch.c)
+target_link_libraries(test-pending-call-dispatch dbus-1)
+install_targets(/bin test-pending-call-dispatch)
+ADD_TEST(test-pending-call-dispatch ${EXECUTABLE_OUTPUT_PATH}/test-pending_call-dispatch)
+
+add_executable(test-thread-init ${NAMEtest-DIR}/test-threads-init.c)
+target_link_libraries(test-thread-init dbus-1)
+install_targets(/bin test-thread-init)
+ADD_TEST(test-names ${EXECUTABLE_OUTPUT_PATH}/test-thread-init)
+
+endif (DBUS_BUILD_TESTS)