summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 69565e17..96d06f07 100644
--- a/configure.in
+++ b/configure.in
@@ -513,7 +513,8 @@ dnl we currently check for all three va_copy possibilities, so we get
dnl all results in config.log for bug reports.
AC_CACHE_CHECK([for an implementation of va_copy()],dbus_cv_va_copy,[
AC_LINK_IFELSE([#include <stdarg.h>
- void f (int i, ...) {
+#include <stdlib.h>
+ static void f (int i, ...) {
va_list args1, args2;
va_start (args1, i);
va_copy (args2, args1);
@@ -530,7 +531,8 @@ AC_CACHE_CHECK([for an implementation of va_copy()],dbus_cv_va_copy,[
])
AC_CACHE_CHECK([for an implementation of __va_copy()],dbus_cv___va_copy,[
AC_LINK_IFELSE([#include <stdarg.h>
- void f (int i, ...) {
+#include <stdlib.h>
+ static void f (int i, ...) {
va_list args1, args2;
va_start (args1, i);
__va_copy (args2, args1);
@@ -563,9 +565,10 @@ AC_CACHE_CHECK([whether va_lists can be copied by value],
[AC_RUN_IFELSE([AC_LANG_PROGRAM(
[[
#include <stdarg.h>
+ #include <stdlib.h>
]],
[[
- void f (int i, ...) {
+ static void f (int i, ...) {
va_list args1, args2;
va_start (args1, i);
args2 = args1;