summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index b3c9773b..3420c741 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,3 +1,5 @@
+## the "name-test" subdir in fact contains a bunch of tests now that need a temporary bus
+## to be running to do stuff with. The directory should be renamed.
SUBDIRS=name-test
DIST_SUBDIRS=name-test
@@ -6,9 +8,11 @@ INCLUDES=-I$(top_srcdir) $(DBUS_TEST_CFLAGS)
if DBUS_BUILD_TESTS
## break-loader removed for now
+## most of these binaries are used in tests but are not themselves tests
TEST_BINARIES=test-service test-names test-shell-service shell-test spawn-test test-segfault test-exit test-sleep-forever
-#enable stand alone make check test
+## these are the things to run in make check (i.e. they are actual tests)
+## (binaries in here must also be in TEST_BINARIES)
TESTS=shell-test
else
TEST_BINARIES=